aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-newt_syrup
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-02 10:57:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-02 10:57:22 +0000
commite3fdca22e6deb5de0e212d94d6479bb3300990ee (patch)
tree49d5fa56c40135f28fdca3ce862d2a986e230e50 /testing/py-newt_syrup
parent5c58bdbc965aca4a880ae4c342133ae2299485cc (diff)
downloadaports-e3fdca22e6deb5de0e212d94d6479bb3300990ee.tar.bz2
aports-e3fdca22e6deb5de0e212d94d6479bb3300990ee.tar.xz
testing/py-newt_syrup: new aport
Newt Syrup is an app framework built on top of Newt http://newt-syrup.fedorahosted.org/
Diffstat (limited to 'testing/py-newt_syrup')
-rw-r--r--testing/py-newt_syrup/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py-newt_syrup/APKBUILD b/testing/py-newt_syrup/APKBUILD
new file mode 100644
index 0000000000..5bba5059d6
--- /dev/null
+++ b/testing/py-newt_syrup/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-newt_syrup
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="Newt Syrup is an app framework built on top of Newt"
+url="http://newt-syrup.fedorahosted.org/"
+arch="noarch"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://mcpierce.fedorapeople.org/rpms/newt_syrup-$pkgver.tar.gz"
+
+_builddir="$srcdir"/newt_syrup-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b9412ee2483d11da28a09a26c9b70c8d newt_syrup-0.1.2.tar.gz"