aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-nose
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-15 19:43:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:34 +0000
commit91e414bba773b1ea03112d9460026661db285a64 (patch)
treee0c2f8fb5a2c1ff4d6704c3b9c9e5ab407bb34ed /testing/py-nose
parentf84e049b23719ac6f037269bebcc26dad63c8e2a (diff)
downloadaports-91e414bba773b1ea03112d9460026661db285a64.tar.bz2
aports-91e414bba773b1ea03112d9460026661db285a64.tar.xz
testing/py-nose: new aport
A Python unittest module http://readthedocs.org/docs/nose/
Diffstat (limited to 'testing/py-nose')
-rw-r--r--testing/py-nose/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-nose/APKBUILD b/testing/py-nose/APKBUILD
new file mode 100644
index 0000000000..b8e75b27c5
--- /dev/null
+++ b/testing/py-nose/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-nose
+_pkgname=nose
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="A Python unittest module"
+url="http://readthedocs.org/docs/nose/"
+arch="noarch"
+license="LGPL2+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="95d6d32b9d6b029c3c65674bd9e7eabe nose-1.3.0.tar.gz"
+sha256sums="4e63cc3325de75cf98ffad40be72fa69753de824695173178f74c034fe4f5260 nose-1.3.0.tar.gz"
+sha512sums="a3b8060e415560a868599224449a3af636d24a060f1381990b175dcd12f30249edd181179d23aea06b0c755ff3dc821b7a15ed8840f7855530479587d4d814f4 nose-1.3.0.tar.gz"