aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-notifymail
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 15:01:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:32 +0000
commit11407fd5509a5f221e37ba1fd42d527da0cc3665 (patch)
tree001f63149e46699f35186044769476d6af4c2335 /testing/py-notifymail
parent51c1606c1e1cc27f86825654824716f626ec08f0 (diff)
downloadaports-11407fd5509a5f221e37ba1fd42d527da0cc3665.tar.bz2
aports-11407fd5509a5f221e37ba1fd42d527da0cc3665.tar.xz
testing/py-notifymail: new aport
A Python module to send emails https://github.com/davidfstr/notifymail/
Diffstat (limited to 'testing/py-notifymail')
-rw-r--r--testing/py-notifymail/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-notifymail/APKBUILD b/testing/py-notifymail/APKBUILD
new file mode 100644
index 0000000000..a1626f7497
--- /dev/null
+++ b/testing/py-notifymail/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-notifymail
+_pkgname=notifymail
+pkgver=1.0
+pkgrel=0
+pkgdesc="A Python module to send emails"
+url="https://github.com/davidfstr/notifymail/"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="cb4041149033e2e65f4c3bb1e1402324 notifymail-1.0.tar.gz"
+sha256sums="500cdf0601c9e90d4f1258f837393f26dc5610f0a583e031bc3f533bb5e45d5a notifymail-1.0.tar.gz"
+sha512sums="173b87b2b40da85a988c26aecb055c29ae19b3117db9cd9af43574e625afa96eee19ce988d3401fef60f015985157c0ddb6e81ed89f7b7ed5e5b6cee9a279958 notifymail-1.0.tar.gz"