aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-praw
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-17 17:23:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-27 06:18:40 +0000
commit50ee3285c9dbc2c2f7082bd95e233b4c4fd045c8 (patch)
treea91915e2316b8accada5ad9347d0f5af52080c19 /testing/py-praw
parent2ffda0a11bee55e51ffd08059606d56be69a4079 (diff)
downloadaports-50ee3285c9dbc2c2f7082bd95e233b4c4fd045c8.tar.bz2
aports-50ee3285c9dbc2c2f7082bd95e233b4c4fd045c8.tar.xz
testing/py-praw: relax setup.py version constraints
Alpine ships newer versions of decorator, prawcore and six than setup.py allows. Preliminary testing with relaxing the version constraints seem to indicate that newer versions work as well.
Diffstat (limited to 'testing/py-praw')
-rw-r--r--testing/py-praw/APKBUILD10
-rw-r--r--testing/py-praw/relax-version-requirements.patch18
2 files changed, 23 insertions, 5 deletions
diff --git a/testing/py-praw/APKBUILD b/testing/py-praw/APKBUILD
index f2d62ee3d8..e2c51682f3 100644
--- a/testing/py-praw/APKBUILD
+++ b/testing/py-praw/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py-praw
_pkgname=praw
pkgver=4.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Python module to access to reddit's API"
url="https://github.com/praw-dev/praw"
arch="noarch"
@@ -11,7 +11,8 @@ license="GPL-3.0-or-later"
depends="py-update-checker py-requests py-six"
makedepends="python2-dev py-setuptools python3-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/praw-dev/praw/archive/v$pkgver.tar.gz"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/praw-dev/praw/archive/v$pkgver.tar.gz
+ relax-version-requirements.patch"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
@@ -45,6 +46,5 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="889e92d898872196eebf0108c814ff68 praw-4.0.0.tar.gz"
-sha256sums="a204cd131ab8f3b8f35353060b34891b6ef27c9a57d798222af16748346650f8 praw-4.0.0.tar.gz"
-sha512sums="adf33b1e51cbbf1ed96ed57360ba25c9449e6649b6bd923d392c74814a2e296dec5b5bcae963dc8428dfb6d047a2eeaaf1fe6e902cfb9081b0875ab95e9dde6b praw-4.0.0.tar.gz"
+sha512sums="adf33b1e51cbbf1ed96ed57360ba25c9449e6649b6bd923d392c74814a2e296dec5b5bcae963dc8428dfb6d047a2eeaaf1fe6e902cfb9081b0875ab95e9dde6b praw-4.0.0.tar.gz
+d24fe8e817963fdc374d00faf2d18a2383b65feb8a06adc84b77663f43c123824caf03219546dcf3ebbb605e6f31e5f6963291b9aa632a6af8c8009ca38a5f75 relax-version-requirements.patch"
diff --git a/testing/py-praw/relax-version-requirements.patch b/testing/py-praw/relax-version-requirements.patch
new file mode 100644
index 0000000000..3bfac8917c
--- /dev/null
+++ b/testing/py-praw/relax-version-requirements.patch
@@ -0,0 +1,18 @@
+diff --git a/setup.py b/setup.py.new
+index 2cc9975725..1f2e5dffba 100644
+--- a/setup.py
++++ b/setup.py.new
+@@ -36,10 +36,10 @@ setup(name=PACKAGE_NAME,
+ description=('PRAW, an acronym for `Python Reddit API Wrapper`, is a '
+ 'python package that allows for simple access to '
+ 'reddit\'s API.'),
+- install_requires=['decorator >=4.0.9, <4.1',
+- 'prawcore >=0.3.0, <0.4',
++ install_requires=['decorator >=4.0.9, <4.4',
++ 'prawcore >=0.3.0',
+ 'requests >=2.3.0',
+- 'six ==1.10',
++ 'six >=1.10',
+ 'update_checker >=0.12'],
+ keywords='reddit api wrapper',
+ license='Simplified BSD License',