aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-protobuf
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2018-01-03 21:34:59 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2018-01-21 11:01:28 +0100
commitec37c7f5e31a56396d96377ce354c8440d483432 (patch)
tree8a0884ad58c5240aa915d2c38649b41e1c028a5f /testing/py-protobuf
parent04a8784993f9c3c9588e5f193f6b3661a9bf7229 (diff)
downloadaports-ec37c7f5e31a56396d96377ce354c8440d483432.tar.bz2
aports-ec37c7f5e31a56396d96377ce354c8440d483432.tar.xz
testing/py-protobuf: upgrade to 3.5.1
Diffstat (limited to 'testing/py-protobuf')
-rw-r--r--testing/py-protobuf/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/testing/py-protobuf/APKBUILD b/testing/py-protobuf/APKBUILD
index dc05a72e44..da983aa7a0 100644
--- a/testing/py-protobuf/APKBUILD
+++ b/testing/py-protobuf/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Corentin Henry <corentinhenry@gmail.com>
pkgname=py-protobuf
_pkgname=${pkgname#py-}
-pkgver=3.2.0
+pkgver=3.5.1
pkgrel=0
pkgdesc="Google's data interchange format."
url="https://github.com/google/protobuf"
@@ -16,14 +16,20 @@ builddir="$srcdir"/protobuf-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
mkdir -p "$pkgdir"
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
_py2() {
replaces="$pkgname"
depends="${depends//py-/py2-}"
@@ -47,4 +53,4 @@ _py() {
chmod +r "$subpkgdir"/usr/lib/*/site-packages/*/*
}
-sha512sums="d20ecd17712ff66033f73747d789fdb0b8b46f692e6655608a6c1c141fa4f9f489dfccd91653c6876b12b40309c7a462a8c1024e2161e01041f2859f4353dedd py-protobuf-3.2.0.tar.gz"
+sha512sums="4406bb9687a949a92cad27a7c9cdf63dca9c73041e796da6731c0d5076ea8e46299be17e77df453bf94340fe5d96b2b6f2436962a126c3157cf21606b42a60ae py-protobuf-3.5.1.tar.gz"