aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pyechonest
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-03-25 09:24:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-29 13:05:38 +0000
commit3c870aa59871662077a39b66d42f6e1d66c9a489 (patch)
treeef3b5521e5bcdb81421c6a32f671f6c4efce69f6 /testing/py-pyechonest
parent864906e2d2d8edadcdf0fccf016cd4e5eb38bf89 (diff)
downloadaports-3c870aa59871662077a39b66d42f6e1d66c9a489.tar.bz2
aports-3c870aa59871662077a39b66d42f6e1d66c9a489.tar.xz
testing/py-pyechonest: new aport
A Python interface to The Echo Nest APIs https://github.com/echonest/pyechonest
Diffstat (limited to 'testing/py-pyechonest')
-rw-r--r--testing/py-pyechonest/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-pyechonest/APKBUILD b/testing/py-pyechonest/APKBUILD
new file mode 100644
index 0000000000..f64039b76f
--- /dev/null
+++ b/testing/py-pyechonest/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyechonest
+_pkgname=pyechonest
+pkgver=9.0.0
+pkgrel=0
+pkgdesc="A Python interface to The Echo Nest APIs"
+url="https://pypi.python.org/pypi/pyechonest"
+arch="noarch"
+license="BSD"
+depends="python py-simplejson py-setuptools"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c633dce658412e3ec553efd25d7d2686 pyechonest-9.0.0.tar.gz"
+sha256sums="1da4b3b8b457232a7eb35b59a48390b3c208759b01d596acaa71e6a172b40495 pyechonest-9.0.0.tar.gz"
+sha512sums="5294402529cf3ed46fbe8f04cec35ab6ce9f2be5d643d0ca45bbb6a3425add5d443e556b05cb4d246fc2531adc055b12c32443b5cbd5612dd47a57135f299a6c pyechonest-9.0.0.tar.gz"