aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pygfm
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-20 13:23:54 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-21 11:30:23 +0000
commit16c550c734a7470bf5a1867e0b4051f13cd8b408 (patch)
treef3da13cf447d67200fa4c7706252766f9aefff1b /testing/py-pygfm
parentd53f88ccb2df3105ff504cb4e289a26526595ccd (diff)
downloadaports-16c550c734a7470bf5a1867e0b4051f13cd8b408.tar.bz2
aports-16c550c734a7470bf5a1867e0b4051f13cd8b408.tar.xz
testing/py-pygfm: new aport
Diffstat (limited to 'testing/py-pygfm')
-rw-r--r--testing/py-pygfm/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py-pygfm/APKBUILD b/testing/py-pygfm/APKBUILD
new file mode 100644
index 0000000000..c8a93bcefb
--- /dev/null
+++ b/testing/py-pygfm/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-pygfm
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="Basic immutable container types for Python"
+url="https://github.com/tomchristie/itypes"
+arch="noarch"
+license="Unknown"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="py-codecov py-coverage py-coveralls py-markdown"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Zopieux/py-gfm/archive/$pkgver.tar.gz"
+builddir="$srcdir"/py-gfm-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+check() {
+ cd "$builddir"
+ python2 test.py
+ python3 test.py
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="39fa47838ad3517a14a706a79de644cd7b845dd5ef55efda00c4c9f9f95a135f994c1c34804a6cf0fab4f619b7e9b943445219d82d7c705c6540d477ac6a3cc0 py-pygfm-0.1.3.tar.gz"