aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pymaging-png/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-07-19 09:57:20 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-07-19 09:58:06 +0000
commit05de866650fc18d42bd49545c92a2b10e2f3c2fc (patch)
tree56ab888ecb7fab3a127aae4da55809a570b3ea2b /testing/py-pymaging-png/APKBUILD
parent811ea00a61599f2bd7d56e42283420ad20b0f894 (diff)
downloadaports-05de866650fc18d42bd49545c92a2b10e2f3c2fc.tar.bz2
aports-05de866650fc18d42bd49545c92a2b10e2f3c2fc.tar.xz
testing/py-pymaging-png: improve APKBUILD
- don't depend on subpkg explicitly - "replaces" not needed
Diffstat (limited to 'testing/py-pymaging-png/APKBUILD')
-rw-r--r--testing/py-pymaging-png/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/testing/py-pymaging-png/APKBUILD b/testing/py-pymaging-png/APKBUILD
index a5ee83562b..8fe2ed63d3 100644
--- a/testing/py-pymaging-png/APKBUILD
+++ b/testing/py-pymaging-png/APKBUILD
@@ -3,12 +3,12 @@ pkgname=py-pymaging-png
_pkgname=pymaging-png
_commit=83d85c44e4b2342818e6c068065e031a9f81bb9f
pkgver=0.0.20130727
-pkgrel=0
+pkgrel=1
pkgdesc="PNG format support for pymaging"
url="https://github.com/ojii/$_pkgname/"
arch="noarch"
license="MIT custom"
-depends="py2-${pkgname#py-} py3-${pkgname#py-}"
+depends=""
makedepends="python2-dev python3-dev py-setuptools"
checkdepends="py-pymaging"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
@@ -26,20 +26,18 @@ package() {
}
_py2() {
- depends="python2 py2-pymaging"
_py python2
rm -rf "$subpkgdir/usr/bin"
}
_py3() {
- depends="python3 py3-pymaging"
- replaces="$pkgname"
_py python3
}
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"