aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pymaging
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2018-07-17 16:53:41 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-07-19 08:05:51 +0000
commit147d45457a29854ce25fb50eab513092f71bc075 (patch)
tree18a9cf67dff8c3ce74459d9eb361094a9c9b895f /testing/py-pymaging
parentf25999191dda204265274f209c324ce64c2c1a79 (diff)
downloadaports-147d45457a29854ce25fb50eab513092f71bc075.tar.bz2
aports-147d45457a29854ce25fb50eab513092f71bc075.tar.xz
testing/py-pymaging: New aport
Pure Python imaging library https://github.com/ojii/pymaging/
Diffstat (limited to 'testing/py-pymaging')
-rw-r--r--testing/py-pymaging/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/py-pymaging/APKBUILD b/testing/py-pymaging/APKBUILD
new file mode 100644
index 0000000000..5136361f4d
--- /dev/null
+++ b/testing/py-pymaging/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py-pymaging
+_pkgname=pymaging
+_commit=596a08fce5664e58d6e8c96847393fbe987783f2
+pkgver=0.0.20130908
+pkgrel=0
+pkgdesc="Pure Python imaging library"
+url="https://github.com/ojii/$_pkgname/"
+arch="noarch"
+license="BSD-3-Clause MIT custom"
+depends="py2-${pkgname#py-} py3-${pkgname#py-}"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ojii/$_pkgname/archive/$_commit.tar.gz"
+builddir="$srcdir"/$_pkgname-$_commit
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ depends="python2"
+ _py python2
+ rm -rf "$subpkgdir/usr/bin"
+}
+
+_py3() {
+ depends="python3"
+ replaces="$pkgname"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
+sha512sums="757431eb53ee839ae8f341c5021b96a704a78434bb81f843de36c0b8274ca8de603ca5f04bf6e38a5dae39d42be2da05f03119235fe5ca5d34bd10fa30faa813 py-pymaging-0.0.20130908.tar.gz"