aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pyparted
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:51:11 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:51:11 +0000
commitac81757085dbc0e1b2671acf175065a11099f2d6 (patch)
treec30a5cb76682dce8d3d42e2803bfebc2682dcb8a /testing/py-pyparted
parent738671da2e8eee6fef6ea642d866dafc58b3886f (diff)
downloadaports-ac81757085dbc0e1b2671acf175065a11099f2d6.tar.bz2
aports-ac81757085dbc0e1b2671acf175065a11099f2d6.tar.xz
testing/py-pyparted: new aport
Diffstat (limited to 'testing/py-pyparted')
-rw-r--r--testing/py-pyparted/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/py-pyparted/APKBUILD b/testing/py-pyparted/APKBUILD
new file mode 100644
index 0000000000..7b45cd65cd
--- /dev/null
+++ b/testing/py-pyparted/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-pyparted
+_pkgname=pyparted
+pkgver=3.10.7
+pkgrel=0
+pkgdesc="Python bindings for GNU parted (libparted)"
+url="https://github.com/rhinstaller/pyparted"
+arch="all"
+license="GPL2"
+makedepends="python2-dev python3-dev py-setuptools parted-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rhinstaller/${pkgname/py-/}/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+
+
+md5sums="fa09a5a416500e6bd0f63c9c12caf2bb py-pyparted-3.10.7.tar.gz"
+sha256sums="5914e3a60437fe3e3758a9e86ee4a539dfa46cfe18e3df386a5cf1f75a963431 py-pyparted-3.10.7.tar.gz"
+sha512sums="c57fed2a8d04511b12891fd59b6dd6840439aada7e5ebeab14a56e6e4f201c249046ee87d9d25af1b3f02960994efb0a2973f25928a9df85d48bbd1bc196ab07 py-pyparted-3.10.7.tar.gz"