aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-queuelib
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-27 14:31:00 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-27 14:31:00 +0000
commit4049e34bc3c0666541d25849a9e9aed99c8c891e (patch)
tree9644fb4a25dde56c00026e039093644f49b5efbb /testing/py-queuelib
parentabc4e90f782a33d9aaa8ace6c9c2861e5952bd3f (diff)
downloadaports-4049e34bc3c0666541d25849a9e9aed99c8c891e.tar.bz2
aports-4049e34bc3c0666541d25849a9e9aed99c8c891e.tar.xz
testing/py-queuelib: added install_if to pull the right python version
Diffstat (limited to 'testing/py-queuelib')
-rw-r--r--testing/py-queuelib/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/py-queuelib/APKBUILD b/testing/py-queuelib/APKBUILD
index 2b099b9f20..9e0c7d0c13 100644
--- a/testing/py-queuelib/APKBUILD
+++ b/testing/py-queuelib/APKBUILD
@@ -3,13 +3,13 @@
pkgname=py-queuelib
_pkgname=queuelib
pkgver=1.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of persistent (disk-based) queues"
url="https://github.com/scrapy/queuelib"
arch="noarch"
license="BSD"
depends=""
-makedepends="python-dev python3-dev py-setuptools"
+makedepends="python2-dev python3-dev py-setuptools"
install=""
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -29,7 +29,7 @@ package() {
_py() {
local python=$1
pkgdesc="$pkgdesc - $python"
-
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}