aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-queuelib
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-05 14:05:22 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:35:08 +0200
commitfb80108ddfc08850737f18ec19dd5afcad64152f (patch)
tree87ff1feb8b3e426170b9101bef1b74493ce50e32 /testing/py-queuelib
parent3845837c83cfba8a758c6b56ea554e59afece8b1 (diff)
downloadaports-fb80108ddfc08850737f18ec19dd5afcad64152f.tar.bz2
aports-fb80108ddfc08850737f18ec19dd5afcad64152f.tar.xz
testing/py-queuelib: new aport
A collection of persistent (disk-based) queues https://github.com/scrapy/queuelib
Diffstat (limited to 'testing/py-queuelib')
-rw-r--r--testing/py-queuelib/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-queuelib/APKBUILD b/testing/py-queuelib/APKBUILD
new file mode 100644
index 0000000000..88d1b22c81
--- /dev/null
+++ b/testing/py-queuelib/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-queuelib
+_pkgname=queuelib
+pkgver=1.0
+pkgrel=0
+pkgdesc="A collection of persistent (disk-based) queues"
+url="https://github.com/scrapy/queuelib"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4be2b21b307bb5aecf93e0b5bdfdaae0 queuelib-1.0.tar.gz"
+sha256sums="0622dd5ef12e4456de324be076162140aaaa8099f057cdc343447fe2642fcf53 queuelib-1.0.tar.gz"
+sha512sums="d83ba9ab5a4dbdc9cbebb193087a82d511bb411c7123b06ed55716896434847f79f276f5cf36981261558c1b032b67b4b34a85935a631d42bcabde4f7ad86073 queuelib-1.0.tar.gz"