aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-radix
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-08 18:31:35 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-08 18:36:11 +0000
commit17797028206f04159d761d3c0233d2f9c23597c3 (patch)
tree2251d4cbcf04f4419ae73e4388fa9c2f45356298 /testing/py-radix
parent9e15ee2186d3abbcfc3370702e970c126e42057b (diff)
downloadaports-17797028206f04159d761d3c0233d2f9c23597c3.tar.bz2
aports-17797028206f04159d761d3c0233d2f9c23597c3.tar.xz
testing/py-radix: modernize APKBUILD
Diffstat (limited to 'testing/py-radix')
-rw-r--r--testing/py-radix/APKBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/testing/py-radix/APKBUILD b/testing/py-radix/APKBUILD
index a65f35bdbb..f7b648da43 100644
--- a/testing/py-radix/APKBUILD
+++ b/testing/py-radix/APKBUILD
@@ -8,31 +8,20 @@ url="https://github.com/mjschultz/py-radix"
arch="all"
license="BSD"
depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
+makedepends="python2-dev py2-setuptools"
subpackages="$pkgname-doc"
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/mjschultz/py-radix/archive/v${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mjschultz/py-radix/archive/v$pkgver.tar.gz"
-_builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}