aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-rencode
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-04-25 10:00:06 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-04-25 10:00:12 +0000
commitd88f2acca9591e9344670a76ee6aae0fcdcddb83 (patch)
tree089a0aa5f2cd7a7194a4262a5be3679cbc161e70 /testing/py-rencode
parent6e5499bca18c723547152560886ab3bb043c6e8f (diff)
downloadaports-d88f2acca9591e9344670a76ee6aae0fcdcddb83.tar.bz2
aports-d88f2acca9591e9344670a76ee6aae0fcdcddb83.tar.xz
testing/py-rencode: new aport. Fixes #5481
Diffstat (limited to 'testing/py-rencode')
-rw-r--r--testing/py-rencode/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py-rencode/APKBUILD b/testing/py-rencode/APKBUILD
new file mode 100644
index 0000000000..506cf88cf4
--- /dev/null
+++ b/testing/py-rencode/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-rencode
+_pkgname=rencode
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="The rencode module is similar to bencode from the BitTorrent project."
+url="https://pypi.python.org/pypi/rencode"
+arch="all"
+license="GPL3"
+depends="python cython"
+depends_dev=""
+makedepends="$depends_dev py-setuptools cython-dev python-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/aresch/rencode/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="741ee1b994344358517987f1681baf12 py-rencode-1.0.4.tar.gz"
+sha256sums="610eee3d926d56c1e5ff1be9df007e96e07d67a991c88b3f62b3ed109e0091c7 py-rencode-1.0.4.tar.gz"
+sha512sums="a9ef3d90a9d3660f752a496504744104d3c59a59a8671586bb61091e11abf2d7493b77629a17f1298a05f5b812728f45862c0c4190ff223f5512b1ef78b4588c py-rencode-1.0.4.tar.gz"