aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinx-theme-readable
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-17 18:10:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commit4994adaebf1eefb5474d8d9620bd9eb443b7190e (patch)
tree70a074bcb0e5c6ff84c74ac26fb23ebec81bfe4a /testing/py-sphinx-theme-readable
parent5605a52c88b98a20442648cc69c200adadf98f63 (diff)
downloadaports-4994adaebf1eefb5474d8d9620bd9eb443b7190e.tar.bz2
aports-4994adaebf1eefb5474d8d9620bd9eb443b7190e.tar.xz
testing/py-sphinx-theme-readable: new aport
The Readable Sphinx theme https://github.com/ignacysokolowski/sphinx-readable-theme
Diffstat (limited to 'testing/py-sphinx-theme-readable')
-rw-r--r--testing/py-sphinx-theme-readable/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinx-theme-readable/APKBUILD b/testing/py-sphinx-theme-readable/APKBUILD
new file mode 100644
index 0000000000..e08f9ebefe
--- /dev/null
+++ b/testing/py-sphinx-theme-readable/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-readable
+_pkgname=sphinx-readable-theme
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="The Readable Sphinx theme"
+url="https://github.com/ignacysokolowski/sphinx-readable-theme"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8dce92bfe725ac1f99e209d90c3175ae sphinx-readable-theme-0.1.0.tar.gz"
+sha256sums="b18df1dfe39d54b9fdb61d1a27da1cc535d4eb5c8331d86120fe484953b08c8f sphinx-readable-theme-0.1.0.tar.gz"
+sha512sums="983ea34e9a833b607f9d4e240fe8a14e157dca3f6607b31bbf9d2c30b099fc4a1aee0b88e84d723894c29c133d32005eb9fbd4de3ec6c8c8f5cb5e97082d3124 sphinx-readable-theme-0.1.0.tar.gz"