aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinxcontrib-spelling
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-10 09:33:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:52 +0000
commit45f914f9e6953476892af554f13e92522e0256c6 (patch)
tree632800ed701a752cb7292b9f4a5a515908a71b94 /testing/py-sphinxcontrib-spelling
parent1e071a83298829f47e4b51496e98dc1f102447c2 (diff)
downloadaports-45f914f9e6953476892af554f13e92522e0256c6.tar.bz2
aports-45f914f9e6953476892af554f13e92522e0256c6.tar.xz
testing/py-sphinxcontrib-spelling: new aport
Sphinx spelling extension https://pypi.python.org/pypi/sphinxcontrib-spelling
Diffstat (limited to 'testing/py-sphinxcontrib-spelling')
-rw-r--r--testing/py-sphinxcontrib-spelling/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinxcontrib-spelling/APKBUILD b/testing/py-sphinxcontrib-spelling/APKBUILD
new file mode 100644
index 0000000000..27ee3c479b
--- /dev/null
+++ b/testing/py-sphinxcontrib-spelling/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-spelling
+_pkgname=sphinxcontrib-spelling
+pkgver=0.2
+pkgrel=0
+pkgdesc="Sphinx spelling extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-spelling"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx py-enchant"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a538063c6be177975fa08d1cb0975f20 sphinxcontrib-spelling-0.2.tar.gz"
+sha256sums="24c4805d92f0b0c507834475a11e685d17e3e79a16ac7e789155fcab1e7cc338 sphinxcontrib-spelling-0.2.tar.gz"
+sha512sums="2a4fc6056e68c8f0b7d7989b12d3eeb9ddc92a022831a57dd1116e1a3964a7bac792e734eb70f6a1416fb0af71ff264cc31b765d311a5bf8af92dec68521e1e5 sphinxcontrib-spelling-0.2.tar.gz"