aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-testscenarios
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 09:56:16 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 09:56:38 +0000
commit52bab007ba88646684e810c76037f008725759db (patch)
treea8c26f969009c26ead7f8cfccc592b699ccb6695 /testing/py-testscenarios
parente0693032ca6fc455bd4984a5555acb0921ee105b (diff)
downloadaports-52bab007ba88646684e810c76037f008725759db.tar.bz2
aports-52bab007ba88646684e810c76037f008725759db.tar.xz
testing/py-testscenarios: new aport
Diffstat (limited to 'testing/py-testscenarios')
-rw-r--r--testing/py-testscenarios/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/py-testscenarios/APKBUILD b/testing/py-testscenarios/APKBUILD
new file mode 100644
index 0000000000..1035fea748
--- /dev/null
+++ b/testing/py-testscenarios/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-testscenarios
+_pkgname=testscenarios
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="Useful extra bits for Python - things that shold be in the standard library"
+url="https://pypi.python.org/pypi/testscenarios/"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}" ## remove if there are no common Python dependencies
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="f08b868babf504482369c5cb945d3e95bca1cc00f92d5013f6898c488051be0c26dc49aaabcef362aea45450a8d041d9826fb6b5c848beec013fb102d6935521 testscenarios-0.5.0.tar.gz"