aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-tqdm
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-26 19:00:43 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-26 19:15:56 +0100
commitd402cf57dcfeec62732c197df64b5985d7431958 (patch)
tree2774e1ae78cd80849f220303f7c6a4fe9bdf96a7 /testing/py-tqdm
parent3b08d11b92dba14d7b938d6a49d0943d0644da8d (diff)
downloadaports-d402cf57dcfeec62732c197df64b5985d7431958.tar.bz2
aports-d402cf57dcfeec62732c197df64b5985d7431958.tar.xz
testing/py-tqdm: fix code-style, pkgdesc etc.
Diffstat (limited to 'testing/py-tqdm')
-rw-r--r--testing/py-tqdm/APKBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/testing/py-tqdm/APKBUILD b/testing/py-tqdm/APKBUILD
index c12e83d6bd..d33808beb2 100644
--- a/testing/py-tqdm/APKBUILD
+++ b/testing/py-tqdm/APKBUILD
@@ -9,29 +9,23 @@ arch="noarch"
license="MIT"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
-source="
- https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- 0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch
- 0001-Import-sleep-nearer-to-usage.patch
-"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ 0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch
+ 0001-Import-sleep-nearer-to-usage.patch"
builddir="$srcdir/$_pkgname-$pkgver"
-prepare() {
- cd "$builddir"
- default_prepare || return 1
-}
-
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
check() {
- cd "$builddir"
- python2 setup.py test || return 1
- # Broken on our current Python build due to setuptools version conflict
- #python3 setup.py test || return 1
+ cd "$builddir"
+
+ python2 setup.py test
+ # Broken on our current Python build due to setuptools version conflict
+ #python3 setup.py test
}
package() {
@@ -40,8 +34,8 @@ package() {
_py() {
local python="$1"
- pkgdesc="$pkgdesc ${python:6:1}"
- depends="$depends $python"
+ pkgdesc="$pkgdesc ($python)"
+ depends="$python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"