aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-w3lib
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-06 02:15:31 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-06 02:15:31 +0000
commitf543efee1dbda0127f8343a6ca40e49f2e9fbfc2 (patch)
treee200c6e4f7a390e78bbe5489b8bcb88c73921e9a /testing/py-w3lib
parentbd4689987d966473207ca533113f4cd448423739 (diff)
downloadaports-f543efee1dbda0127f8343a6ca40e49f2e9fbfc2.tar.bz2
aports-f543efee1dbda0127f8343a6ca40e49f2e9fbfc2.tar.xz
testing/py-w3lib: upgrade to 1.15.0 and modernize
Diffstat (limited to 'testing/py-w3lib')
-rw-r--r--testing/py-w3lib/APKBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/testing/py-w3lib/APKBUILD b/testing/py-w3lib/APKBUILD
index 337fa6d5ef..ab882f5cb9 100644
--- a/testing/py-w3lib/APKBUILD
+++ b/testing/py-w3lib/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-w3lib
_pkgname=w3lib
-pkgver=1.10.0
+pkgver=1.15.0
pkgrel=0
pkgdesc="A library of web-related functions"
url="https://github.com/scrapy/w3lib"
@@ -15,27 +15,16 @@ install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="4188d2dbc790dd07c6b3877dcd0ebd7b w3lib-1.10.0.tar.gz"
-sha256sums="670cd9647dfc9f5adbf973c300bc62f3ba6687acfed93b67527f4cca5459380b w3lib-1.10.0.tar.gz"
-sha512sums="9f17083b57b3363c4eb656d46b87a122c3dcac0a58bf4f9fd9aab7d28776931d16eb9b5c7f267cfeb8e7f52d695e9b22f5f83b724fd671a70073325972088b2f w3lib-1.10.0.tar.gz"
+sha512sums="debf3aed14f423eb36d730802cf23a393ec9364bd91d158b9a78a8e6deeb23886dea62a8cd47ab120b080c3b82c19aa6fc2865fdeb33add45a45389dbbfae5fa w3lib-1.15.0.tar.gz"