aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-xlib
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-06-02 08:32:19 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-02 08:32:44 +0000
commit62be9f37fa1fef31438835410f9e8153b1a5c87a (patch)
tree0834545a0986cf25bbf59e1db68379db3363e818 /testing/py-xlib
parent146b2a4eb2aa87c07bd9034c7b8ed49e4184855c (diff)
downloadaports-62be9f37fa1fef31438835410f9e8153b1a5c87a.tar.bz2
aports-62be9f37fa1fef31438835410f9e8153b1a5c87a.tar.xz
testing/py-xlib: make check() succeded
Diffstat (limited to 'testing/py-xlib')
-rw-r--r--testing/py-xlib/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/py-xlib/APKBUILD b/testing/py-xlib/APKBUILD
index 1a2d34bc3c..1ff0c32fd6 100644
--- a/testing/py-xlib/APKBUILD
+++ b/testing/py-xlib/APKBUILD
@@ -3,12 +3,13 @@
pkgname=py-xlib
_pkgname=python-xlib
pkgver=0.19
-pkgrel=0
+pkgrel=1
pkgdesc="A fully functional X client library for Python programs"
url="https://github.com/python-xlib/python-xlib"
arch="noarch"
license="LGPL2"
depends="py-six"
+checkdepends="xvfb"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="${pkgname/py-/py3-}:_py3 ${pkgname/py-/py2-}:_py2"
source="https://github.com/$_pkgname/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.bz2"
@@ -22,6 +23,8 @@ build() {
check() {
cd "$builddir"
+ Xvfb :1 &
+ export DISPLAY=:1
python2 setup.py test
python3 setup.py test
}