aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-xlwt
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-08-06 17:42:30 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-08-06 19:31:52 +0000
commitecd2a5b55f7508075da554970f4726d4ce0a3e24 (patch)
tree65458fbe1f7e5a0b58dd4ad9652d6f2c782c36a3 /testing/py-xlwt
parentcccb1c700ab036f0454fd4f4ece43741cfd8a557 (diff)
downloadaports-ecd2a5b55f7508075da554970f4726d4ce0a3e24.tar.bz2
aports-ecd2a5b55f7508075da554970f4726d4ce0a3e24.tar.xz
testing/py-xlwt: new aport
xlwt is a library for generating spreadsheet files that are compatible with Excel 97/2000/XP/2003, OpenOffice.org Calc, and Gnumeric. xlwt has full support for Unicode. Excel spreadsheets can be generated on any platform without needing Excel or a COM server. http://pypi.python.org/pypi/xlwt/
Diffstat (limited to 'testing/py-xlwt')
-rw-r--r--testing/py-xlwt/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-xlwt/APKBUILD b/testing/py-xlwt/APKBUILD
new file mode 100644
index 0000000000..3de72cb5b3
--- /dev/null
+++ b/testing/py-xlwt/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-xlwt
+_pkgname=xlwt
+pkgver=0.7.4
+pkgrel=0
+pkgdesc="A library to create spreadsheet files"
+url="http://pypi.python.org/pypi/xlwt/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="231f4ff30894fc70d142b4ed1ba71cc0 xlwt-0.7.4.tar.gz"