aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-xmltodict
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 04:23:12 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 04:23:12 +0000
commitc64278228661502a9d321c6b2f6764e1117fc31b (patch)
tree4405f1f8305963ab5b14c8df2802476fc0cdce2b /testing/py-xmltodict
parent9a9a043ef5fe2314ccc7c4d64dc0729e39e4e2b2 (diff)
downloadaports-c64278228661502a9d321c6b2f6764e1117fc31b.tar.bz2
aports-c64278228661502a9d321c6b2f6764e1117fc31b.tar.xz
testing/py-xmltodict: new aport
Diffstat (limited to 'testing/py-xmltodict')
-rw-r--r--testing/py-xmltodict/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-xmltodict/APKBUILD b/testing/py-xmltodict/APKBUILD
new file mode 100644
index 0000000000..d0996f4828
--- /dev/null
+++ b/testing/py-xmltodict/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-xmltodict
+pkgver=0.11.0
+pkgrel=0
+pkgdesc="an xmltodict implementation"
+url="https://pypi.python.org/pypi/xmltodict/"
+arch="noarch"
+license="BSD"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-xmltodict:py2 py3-xmltodict:py3"
+source="https://files.pythonhosted.org/packages/source/x/xmltodict/xmltodict-$pkgver.tar.gz"
+builddir="$srcdir/xmltodict-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="d42ef146a40f386a5389958f890605c560ce9db2da4447099b8725edc1998339b77ea732576fc7e77fbe5a755a2dc3239dfae4a82fc6593c5f977145ab445295 xmltodict-0.11.0.tar.gz"