aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hbmqtt
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-12-28 15:44:43 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-28 19:20:01 +0200
commit6f2de40c0afc8e740c4a49f8464c57ef5e6f46b1 (patch)
treeb7ec5924b3376193d931df66e5d534536eef4467 /testing/py3-hbmqtt
parent98d1dca9e329dbe39ee3f3f807827444c47bc85e (diff)
downloadaports-6f2de40c0afc8e740c4a49f8464c57ef5e6f46b1.tar.bz2
aports-6f2de40c0afc8e740c4a49f8464c57ef5e6f46b1.tar.xz
testing/py3-hbmqtt: new aport
MQTT client/broker using Python asynchronous I/O http://hbmqtt.readthedocs.io/
Diffstat (limited to 'testing/py3-hbmqtt')
-rw-r--r--testing/py3-hbmqtt/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-hbmqtt/APKBUILD b/testing/py3-hbmqtt/APKBUILD
new file mode 100644
index 0000000000..3465e1c3a2
--- /dev/null
+++ b/testing/py3-hbmqtt/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-hbmqtt
+_pkgname=hbmqtt
+pkgver=0.8
+pkgrel=0
+pkgdesc="MQTT client/broker using Python asynchronous I/O"
+url="http://hbmqtt.readthedocs.io/"
+arch="noarch"
+license="MIT"
+depends="py3-passlib py3-websockets py3-transitions py3-docopt py3-yaml"
+makedepends="python3-dev"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/beerfactory/hbmqtt/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+}
+
+md5sums="d89361972a1f4a5ae3decc288d400c77 hbmqtt-0.8.tar.gz"
+sha256sums="91c3d5558ed596d2182cb4e56ea14be29d1a5005747bb3b725ccb3bb0988ef82 hbmqtt-0.8.tar.gz"
+sha512sums="c901ed61c63bc13387fbd38a213aa1e7d59861e090a2e73132779c03c455ce1d81f4bc61536b44c1c3184b67973c1affbdd8c72b355e94995e2a2c016c99dadf hbmqtt-0.8.tar.gz"