aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-llfuse
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-14 00:54:24 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-14 00:54:40 +0100
commitc3a70b29be3cd3c1dc5f5930e975f6bf1edbbd7c (patch)
treeed9b9b26b10b3b523b2ea7548d555878729104ef /testing/py3-llfuse
parent811f6d4d0ab53b10e045ed937d9ba261085023a0 (diff)
downloadaports-c3a70b29be3cd3c1dc5f5930e975f6bf1edbbd7c.tar.bz2
aports-c3a70b29be3cd3c1dc5f5930e975f6bf1edbbd7c.tar.xz
testing/py3-llfuse: new aport
https://bitbucket.org/nikratio/python-llfuse/ Python bindings for the low-level FUSE API
Diffstat (limited to 'testing/py3-llfuse')
-rw-r--r--testing/py3-llfuse/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-llfuse/APKBUILD b/testing/py3-llfuse/APKBUILD
new file mode 100644
index 0000000000..4af362bd44
--- /dev/null
+++ b/testing/py3-llfuse/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+# TODO: Add check (needs pytest-checklog).
+pkgname=py3-llfuse
+_pkgname=llfuse
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Python bindings for the low-level FUSE API"
+url="https://bitbucket.org/nikratio/python-llfuse/"
+arch="all"
+license="LGPL"
+makedepends="python3-dev fuse-dev attr-dev"
+checkdepends="pytest"
+subpackages="$pkgname-doc"
+source="https://bitbucket.org/nikratio/python-llfuse/downloads/$_pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f065818134b12dd128574836bc7d339404d9b7d9236b535da709378e9206b17cb2accd97fc0b658f39a93efe126a7c3064f7901468231f63f8398a3e053498cf llfuse-1.3.2.tar.bz2"