aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qbittorrent-nox
diff options
context:
space:
mode:
authorJan Tatje <jan@jnt.io>2018-08-06 04:19:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-30 14:49:30 +0000
commitbef30b647957f29d6df27273f7bc03d36130ab4b (patch)
tree7954e061a1d9a1faf03b21d2d69b36d03c7c28ea /testing/qbittorrent-nox
parentc257a29be6c4ab248d3b6319e80e13c495517530 (diff)
downloadaports-bef30b647957f29d6df27273f7bc03d36130ab4b.tar.bz2
aports-bef30b647957f29d6df27273f7bc03d36130ab4b.tar.xz
testing/qbittorrent-nox: new aport
Diffstat (limited to 'testing/qbittorrent-nox')
-rw-r--r--testing/qbittorrent-nox/APKBUILD41
-rw-r--r--testing/qbittorrent-nox/qbittorrent-nox.confd3
-rw-r--r--testing/qbittorrent-nox/qbittorrent-nox.initd16
-rw-r--r--testing/qbittorrent-nox/qbittorrent-nox.pre-install6
4 files changed, 66 insertions, 0 deletions
diff --git a/testing/qbittorrent-nox/APKBUILD b/testing/qbittorrent-nox/APKBUILD
new file mode 100644
index 0000000000..d01d7e800a
--- /dev/null
+++ b/testing/qbittorrent-nox/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jan Tatje <jan@jnt.io>
+# Maintainer: Jan Tatje <jan@jnt.io>
+pkgname=qbittorrent-nox
+pkgver=4.1.2
+pkgrel=0
+pkgdesc="qBittorrent client (webui only)"
+url="https://www.qbittorrent.org/"
+arch="x86_64"
+license="GPL2"
+options="!check" # qBittorrent has no tests
+depends="boost qt5-qtbase libtorrent-rasterbar"
+makedepends="boost-dev qt5-qtbase-dev qt5-qttools-dev libtorrent-rasterbar-dev"
+install="$pkgname.pre-install"
+subpackages="$pkgname-openrc $pkgname-doc"
+source="
+ qbittorrent-nox.initd
+ qbittorrent-nox.confd
+ https://github.com/qbittorrent/qBittorrent/archive/release-$pkgver.tar.gz
+ "
+builddir="$srcdir/"
+
+build() {
+ cd "$builddir/qBittorrent-release-$pkgver"
+ ./configure --disable-gui --disable-qt-dbus --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir/qBittorrent-release-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="310df13ca8249e2ed57b7490ffa8f6beb0b273d856a62eeb87d47b7c20c531224c03c07124c3b9ac287c00dd9c139180c39933ee33dcb1a8a6ec1f67605dcede qbittorrent-nox.initd
+999e58bcf0a528f88655611cb7d0ec2bd5f0a1aed1696b71be27e24a1708112540afa7fb37688ec865de1d9c7af6e7a2293773790bd8941bb94a1dc1f9ebe95e qbittorrent-nox.confd
+25293378693cec875d1b52ea5aca8087a0d31021e6fbb4bd31f05c6979e36a5dc03983f2007a067942e1e119878b94a9e2b9622f324c7592f6630dcfe008b757 release-4.1.2.tar.gz"
diff --git a/testing/qbittorrent-nox/qbittorrent-nox.confd b/testing/qbittorrent-nox/qbittorrent-nox.confd
new file mode 100644
index 0000000000..f216b14f28
--- /dev/null
+++ b/testing/qbittorrent-nox/qbittorrent-nox.confd
@@ -0,0 +1,3 @@
+#qbittorrent
+
+qbittorrent_opts=""
diff --git a/testing/qbittorrent-nox/qbittorrent-nox.initd b/testing/qbittorrent-nox/qbittorrent-nox.initd
new file mode 100644
index 0000000000..cac8e5e341
--- /dev/null
+++ b/testing/qbittorrent-nox/qbittorrent-nox.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+
+# init.d file for qbittorrent-nox.
+
+name=qbittorrent-nox
+user=qbittorrent
+group=qbittorrent
+command="/usr/bin/$name"
+command_args="-d $qbittorrent_opts"
+
+start_stop_daemon_args="--user $user:$group"
+
+depend() {
+ need net
+ after firewall
+}
diff --git a/testing/qbittorrent-nox/qbittorrent-nox.pre-install b/testing/qbittorrent-nox/qbittorrent-nox.pre-install
new file mode 100644
index 0000000000..87016a2233
--- /dev/null
+++ b/testing/qbittorrent-nox/qbittorrent-nox.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S qbittorrent 2>/dev/null
+adduser -S -D -h /var/lib/qbittorrent -s /sbin/nologin -G qbittorrent -g qbittorrent qbittorrent 2>/dev/null
+
+exit 0