aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qt-creator
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-04-05 14:42:57 +0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-05 14:42:57 +0300
commit5aec3a1d31ccb236aa25ee7025e311ea913d836c (patch)
tree7b804f095727c69743bc17cd90844a30f8dd5aca /testing/qt-creator
parentd625d78fbc97665e3d7185026bf9691a0d0ba62e (diff)
downloadaports-5aec3a1d31ccb236aa25ee7025e311ea913d836c.tar.bz2
aports-5aec3a1d31ccb236aa25ee7025e311ea913d836c.tar.xz
testing/qt-creator: apply upstream arm build fix
Diffstat (limited to 'testing/qt-creator')
-rw-r--r--testing/qt-creator/APKBUILD4
-rw-r--r--testing/qt-creator/qtcreator-arm.patch78
2 files changed, 82 insertions, 0 deletions
diff --git a/testing/qt-creator/APKBUILD b/testing/qt-creator/APKBUILD
index a33c2323f9..db98c5e0b6 100644
--- a/testing/qt-creator/APKBUILD
+++ b/testing/qt-creator/APKBUILD
@@ -14,6 +14,7 @@ install=""
subpackages=""
ldpath="/usr/lib/qtcreator:/usr/lib/qtcreator/plugins/Nokia"
source="http://download.qt-project.org/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.gz
+ qtcreator-arm.patch
fix-headers-musl.patch
fix-execinfo.patch
qtcreator.desktop"
@@ -45,14 +46,17 @@ package() {
}
md5sums="1d736f4b3c25c25cf070c400a92e50c4 qt-creator-opensource-src-3.0.1.tar.gz
+9fb12108134fcbd716f884c150680056 qtcreator-arm.patch
0e31a207fd72013b10dbf3cc1ebf0651 fix-headers-musl.patch
f2645b7f79dde965ed57b948fadf19a7 fix-execinfo.patch
f8b1f18e8d62cd4734bb676a97cee1dc qtcreator.desktop"
sha256sums="829f1608c1c7304c907548315317520bf24cf5db711775d4d5f827607affdf98 qt-creator-opensource-src-3.0.1.tar.gz
+4bdf1ba9f12469de0092a9c09088e63090f2200224ede6939e565aa8c3901b20 qtcreator-arm.patch
10e0e48ef7855c760e34d2bc50719b17ed12429a42090f95d3f7ddfb3562b57b fix-headers-musl.patch
c460933c25ef1ff098a047b1403b90dd7ea439e13d06ec42fec32bf6b8b26390 fix-execinfo.patch
849194d74b8fe1dd8ce78c39371256cd80a7cb3a79ec130dea36c8fd6155f88d qtcreator.desktop"
sha512sums="fa8b2c4196136b310127daf308a5a99b0ef39b2e25db83930f959a034418a08590edbe8e19e6afea02c1d647602bb49c96df8db156d24f6b9b9246c1a93ead19 qt-creator-opensource-src-3.0.1.tar.gz
+b2d3a256db69512c693194234ff25d97ec58f19879b80d70d8fdac1f1f412aff1fddfe4d5fd0be98f77d7085d000aaa2ddb67cb1fe5d5a49be1d7fe8c95e7109 qtcreator-arm.patch
f523b9da264265a01c7e3c6c298c3ea2098b1d15baa16a38dee6b3bd5b696dff6a5b7d32040fee2ad1d88bec3119a4d83029714e88cd56f5fb8f725694a742e6 fix-headers-musl.patch
d145e037a7871a60309c0db70a30cbe1e7fac04756ff9445c8689cc56ac06838387db67ed8a3395200ecee0b7fd73108e3b5231b643f0eee6f9a02783f6278a8 fix-execinfo.patch
b694063d2c91bfcf1cad25845c32158f35b8659f03ab9beebbadd98d06f01324ceafca682c2145025f6155c4f1d86bcba3bdcae4f54d5b5d71fc813aaf129a48 qtcreator.desktop"
diff --git a/testing/qt-creator/qtcreator-arm.patch b/testing/qt-creator/qtcreator-arm.patch
new file mode 100644
index 0000000000..ee6ad5326c
--- /dev/null
+++ b/testing/qt-creator/qtcreator-arm.patch
@@ -0,0 +1,78 @@
+https://bugreports.qt.io/browse/QTCREATORBUG-8107
+
+diff --git a/src/libs/3rdparty/botan/botan.cpp b/src/libs/3rdparty/botan/botan.cpp
+index 917c385..4364a2e 100644
+--- a/src/libs/3rdparty/botan/botan.cpp
++++ b/src/libs/3rdparty/botan/botan.cpp
+@@ -1101,6 +1101,8 @@ class Montgomery_Exponentiator : public Modular_Exponentiator
+
+ #if (BOTAN_MP_WORD_BITS != 32)
+ #error The mp_x86_32 module requires that BOTAN_MP_WORD_BITS == 32
++#elif !defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
++typedef Botan::u64bit dword;
+ #endif
+
+ #ifdef Q_OS_UNIX
+@@ -1118,6 +1120,7 @@ extern "C" {
+ */
+ inline word word_madd2(word a, word b, word* c)
+ {
++#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
+ asm(
+ ASM("mull %[b]")
+ ASM("addl %[c],%[a]")
+@@ -1127,6 +1130,11 @@ inline word word_madd2(word a, word b, word* c)
+ : "0"(a), "1"(b), [c]"g"(*c) : "cc");
+
+ return a;
++#else
++ dword z = (dword)a * b + *c;
++ *c = (word)(z >> BOTAN_MP_WORD_BITS);
++ return (word)z;
++#endif
+ }
+
+ /*
+@@ -1134,6 +1142,7 @@ inline word word_madd2(word a, word b, word* c)
+ */
+ inline word word_madd3(word a, word b, word c, word* d)
+ {
++#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
+ asm(
+ ASM("mull %[b]")
+
+@@ -1147,6 +1156,11 @@ inline word word_madd3(word a, word b, word c, word* d)
+ : "0"(a), "1"(b), [c]"g"(c), [d]"g"(*d) : "cc");
+
+ return a;
++#else
++ dword z = (dword)a * b + c + *d;
++ *d = (word)(z >> BOTAN_MP_WORD_BITS);
++ return (word)z;
++#endif
+ }
+
+ }
+@@ -2315,7 +2329,7 @@ namespace Botan {
+
+ extern "C" {
+
+-#ifdef Q_OS_UNIX
++#if defined(Q_OS_UNIX) && defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
+ /*
+ * Helper Macros for x86 Assembly
+ */
+diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
+index 6a9cbe0..8afec9e 100644
+--- a/src/libs/3rdparty/botan/botan.h
++++ b/src/libs/3rdparty/botan/botan.h
+@@ -81,7 +81,9 @@
+ #endif
+
+ #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
++#if !defined(__arm__)
+ #define BOTAN_TARGET_CPU_IS_X86_FAMILY
++#endif
+ #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
+
+ #if defined(BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN) || \