aboutsummaryrefslogtreecommitdiffstats
path: root/testing/radicale
diff options
context:
space:
mode:
authorStefan Wagner <stw@bit-strickerei.de>2016-11-22 15:55:20 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-22 16:43:37 +0100
commit9144c88c339320172a33a7b157e70677c1988a0d (patch)
tree20ea0b2df4bbcd67b3dea22b42b86ebe1d9cce8a /testing/radicale
parentf1b75d340e63d05d50acdf62dfb2f572b9d991dc (diff)
downloadaports-9144c88c339320172a33a7b157e70677c1988a0d.tar.bz2
aports-9144c88c339320172a33a7b157e70677c1988a0d.tar.xz
testing/radicale: fix permissions for config files
Radicale is started as user radicale, so the config should be readable by this user. Currently the config files aren't world readable, which makes the application crash on startup.
Diffstat (limited to 'testing/radicale')
-rw-r--r--testing/radicale/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/radicale/APKBUILD b/testing/radicale/APKBUILD
index 214f5bb3f3..5fbdf7a015 100644
--- a/testing/radicale/APKBUILD
+++ b/testing/radicale/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=radicale
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A simple CalDAV (calendar) and CardDAV (contact) server"
url="http://radicale.org"
arch="noarch"
@@ -40,8 +40,8 @@ package() {
--root="$pkgdir" || return 1
install -d "$pkgdir"/etc/radicale
- install -m640 config "$pkgdir"/etc/radicale/ || return 1
- install -m640 logging "$pkgdir"/etc/radicale/ || return 1
+ install -m640 -g radicale config "$pkgdir"/etc/radicale/ || return 1
+ install -m640 -g radicale logging "$pkgdir"/etc/radicale/ || return 1
install -d -o radicale "$pkgdir"/var/lib/radicale \
"$pkgdir"/var/log/radicale || return 1