aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rippled
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-05-16 10:20:13 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-05-16 17:31:36 +0300
commit6a6ffb3f3949779cdbe2e6758e8a8ff62b5c6201 (patch)
treed610d31e6181416fb654be33d953950fe4008169 /testing/rippled
parent2c4bd574a759f519863f3276086ac04d1fa15ec9 (diff)
downloadaports-6a6ffb3f3949779cdbe2e6758e8a8ff62b5c6201.tar.bz2
aports-6a6ffb3f3949779cdbe2e6758e8a8ff62b5c6201.tar.xz
testing/rippled: upgrade to 1.0.0
Diffstat (limited to 'testing/rippled')
-rw-r--r--testing/rippled/APKBUILD10
-rw-r--r--testing/rippled/musl-fixes.patch13
2 files changed, 5 insertions, 18 deletions
diff --git a/testing/rippled/APKBUILD b/testing/rippled/APKBUILD
index 760187f8df..2120cbbfd0 100644
--- a/testing/rippled/APKBUILD
+++ b/testing/rippled/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=rippled
-pkgver=0.90.1
+pkgver=1.0.0
pkgrel=0
pkgdesc="Blockchain daemon implementing the Ripple Consensus Ledger"
url="https://ripple.com/"
@@ -30,9 +30,9 @@ package() {
cd "$builddir"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
install -D build/rippled "${pkgdir}/usr/bin/rippled"
- install -D -m644 doc/rippled-example.cfg "${pkgdir}/etc/$pkgname/rippled.cfg"
- install -D -m644 doc/validators-example.txt "${pkgdir}/etc/$pkgname/validators.txt"
+ install -D -m644 cfg/rippled-example.cfg "${pkgdir}/etc/$pkgname/rippled.cfg"
+ install -D -m644 cfg/validators-example.txt "${pkgdir}/etc/$pkgname/validators.txt"
}
-sha512sums="30d55142f759c577cef948084663e6911aeb01587246f4cd443c85a50cc85b5abd6519df0ee0fd30ee421f600730e80d921c9d2961828b8f904373f263c3a0df rippled-0.90.1.tar.gz
-8e313f63096993b8898c6bbbf81671f01fbad84f29b882fe8f164662b2e1487255a4135e978d8a9d2ee18b64fc90be0440109654f9aeef7d65a940b7dd174d5d musl-fixes.patch"
+sha512sums="13819b7c2718178a07487a32f78598862dd2b91d1a95237912cb40c56acf4b8a8ea5bf771414bdf4871c81e2856610c7feb6cf37be8fff9a08fce60c0a1e9ce8 rippled-1.0.0.tar.gz
+fb063fa49278a5ffbe3fb3f2c348e83f0b936bc35cab181ef02575f4a3a2ad08997dad970b101b5d9796706757e29cd1d1546da1b550e875be08d01c7e31ef16 musl-fixes.patch"
diff --git a/testing/rippled/musl-fixes.patch b/testing/rippled/musl-fixes.patch
index 7b5710e4ac..c7615d7e1d 100644
--- a/testing/rippled/musl-fixes.patch
+++ b/testing/rippled/musl-fixes.patch
@@ -34,19 +34,6 @@ index 2a24bf8..ddaaa2c 100644
namespace rocksdb {
-diff --git a/src/ripple/beast/core/SystemStats.cpp b/src/ripple/beast/core/SystemStats.cpp
-index 74caa79..b238979 100644
---- a/src/ripple/beast/core/SystemStats.cpp
-+++ b/src/ripple/beast/core/SystemStats.cpp
-@@ -50,7 +50,7 @@ getStackBacktrace()
- {
- std::vector <std::string> result;
-
--#if BEAST_ANDROID || BEAST_MINGW || BEAST_BSD
-+#if BEAST_ANDROID || BEAST_MINGW || BEAST_BSD || 1
- assert(false); // sorry, not implemented yet!
-
- #elif BEAST_WINDOWS
diff --git a/src/ripple/beast/core/core.unity.cpp b/src/ripple/beast/core/core.unity.cpp
index 83dd1df..b374634 100644
--- a/src/ripple/beast/core/core.unity.cpp