aboutsummaryrefslogtreecommitdiffstats
path: root/testing/runit
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-12-19 17:55:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-01-06 14:17:59 +0000
commita7cfdfd28f45309a34e2fb359f5d07cf12a98ce2 (patch)
treea12f0b2de1e362e6e77630cd4d8e4200af41df40 /testing/runit
parentef4898b7ef7405e4bb46628b0d574847f5a7adad (diff)
downloadaports-a7cfdfd28f45309a34e2fb359f5d07cf12a98ce2.tar.bz2
aports-a7cfdfd28f45309a34e2fb359f5d07cf12a98ce2.tar.xz
testing/runit: add mysqld / postgresql example run scripts
Diffstat (limited to 'testing/runit')
-rw-r--r--testing/runit/APKBUILD8
-rw-r--r--testing/runit/README.alpine19
2 files changed, 22 insertions, 5 deletions
diff --git a/testing/runit/APKBUILD b/testing/runit/APKBUILD
index 5f15a0f9a3..fea0f14f38 100644
--- a/testing/runit/APKBUILD
+++ b/testing/runit/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=runit
pkgver=2.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="UNIX init scheme with service supervision"
url="http://smarden.org/runit/"
arch="all"
@@ -54,13 +54,13 @@ package() {
md5sums="6c985fbfe3a34608eb3c53dc719172c4 runit-2.1.2.tar.gz
13b3d1e097d58c7fe78c8c2ae9c829ff run-service-dir.patch
-83c4afc69c119a070bf9fec41be1b2a2 README.alpine
+735265c11ac8653fe61615e5756af272 README.alpine
df31f105e66ee755fd990ba7184884ed runit.initd"
sha256sums="6fd0160cb0cf1207de4e66754b6d39750cff14bb0aa66ab49490992c0c47ba18 runit-2.1.2.tar.gz
b051476a9cea0673cdd3f849c33555e364540f49436ab7d05f5aeee553d84ab7 run-service-dir.patch
-335bc330671a361627c9e8d81a3afecdedab3dd2b17a36f4f0b2a3084469e9ab README.alpine
+6a49cdf4c9fd8326d9e3fed3df8ff6fae47f60fd586b56d561e0b2d629ea949a README.alpine
aed913227ba4035fe0a84423610817f551ea890d5c5d5a64399b504b2d6f7cc1 runit.initd"
sha512sums="a18773ebf1aa22305dd89ed67363165b9fcf86c192b2be4e268d08005dd82d51265160c637abe072f2f2e378c4b315a75bd3d3e602c3e75bdd451a3b0190f8cf runit-2.1.2.tar.gz
7107da162f7c13e1483f17bf04a844c23a8d1b81ef982c3d956a4c0e23b2a20e415850f0b95999b1eb1e04638284884948937377756ca080037bd6455e3301e8 run-service-dir.patch
-066edd570cb60fa15b580fb2f9c80835569020829fb5893db6d2e3003148b0c78225fba6886a5520a1e203d1b55f6b05b287c0ca9cce5f62c3052d007b2e7791 README.alpine
+88d1efcf366add7803ed026ec8e693b271c842d4e3d5a52587b7ead96266ee27b4ceb1b2696551243f0d9efa93199a07231d2b37186ce1535e9a6b9d90192909 README.alpine
32487bec20e1313eae2e9f315b5b82c67c93c11f15b737f00469006f5fd7f2944ac91887e6ceefa2934fc02f83d4184af9db74acad381a4d9caf952f76621a60 runit.initd"
diff --git a/testing/runit/README.alpine b/testing/runit/README.alpine
index 16fb7dc5b7..e6b04f03e2 100644
--- a/testing/runit/README.alpine
+++ b/testing/runit/README.alpine
@@ -16,7 +16,24 @@ set -e
ssh-keygen -A
exec /usr/sbin/sshd -D
------------------------------
-Example: /etc/sv/tinyssh/run |
+Example: /etc/sv/mysqld/run |
+------------------------------
+#!/bin/sh
+libs=/var/lib/mysql
+socket=/run/mysqld
+mkdir -p $socket
+chown mysql:mysql $socket
+chown -R mysql:mysql $libs
+exec chpst -u mysql:mysql mysqld --user=mysql 2>&1
+--------------------------------------------------
+Example: /etc/sv/pgsql/run |
+--------------------------------------------------
+#!/bin/sh
+. /etc/conf.d/postgresql
+chown -R postgres:postgres ${PGDATA}
+exec setuidgid postgres /usr/bin/postgres -D ${PGDATA} -o "$PGOPTS" 2>&1
+---------------------------------------------------------------------------------
+Example: /etc/sv/tinyssh/run |
---------------------------------------------------------------------------------
#!/bin/sh
PORT=22