aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rust
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-04-16 15:57:13 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-04-21 01:44:33 +0200
commit9e94cc5fbd98ff048290548c2077ef0ce3be3c96 (patch)
treea2e1c811edf3092ea32973168ee43296a686563f /testing/rust
parent3db351aa5647eb4a482e9e008bedcf1a5be51302 (diff)
downloadaports-9e94cc5fbd98ff048290548c2077ef0ce3be3c96.tar.bz2
aports-9e94cc5fbd98ff048290548c2077ef0ce3be3c96.tar.xz
testing/rust: remove FileCheck removal patch
This is no longer needed with our LLVM 3.9 package, as we ship FileCheck now.
Diffstat (limited to 'testing/rust')
-rw-r--r--testing/rust/APKBUILD3
-rw-r--r--testing/rust/alpine-dont-require-filecheck.patch19
2 files changed, 1 insertions, 21 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index 537dd2f7bf..abb8f721c4 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -36,7 +36,6 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz
llvm-with-ffi.patch
alpine-musl-dynamic-linking-by-default.patch
alpine-allow-crt-static.patch
- alpine-dont-require-filecheck.patch
alpine-move-py-scripts-to-share.patch
alpine-change-rpath-to-rustlib.patch
alpine-force-rpath-on-prefer-dynamic.patch
@@ -194,7 +193,7 @@ dc6432293bd060d5e3a73f25870867654fae61995dcd919e244a2dc686b6107556deed8c59ca6002
44f3104f506531778fede64034ff5b86f782744d7fed26b393cd88590c22b7fd1df441e2c14bb44c660c54140a4093686aa35f53357f9cd795af6cfa6df1cec4 alpine-musl-dynamic-linking-by-default.patch
b00997c65d1a451fafae8b547893c5cbf03f028d2d70f6971aa670f34c2d6fc82728c740ac4a9909fc1999925ff300e4525cfec745cb9c9521e564eb166872a2 alpine-allow-crt-static.patch
2002faf08cca3be702f25618bc17453c5e76644a6ff6b0739b642c2c0f8536ec7f09c98182aff6b2dcc87c77b0929f2f8f732b8242a8f80d94b3824c8cd0d0fe alpine-dont-require-filecheck.patch
-498f4649163974afc4f042c43cd0c15d36784031514201a2962061f288a9336c2bc9749f8d2308b8ce3656f8097b5fc5bef505f61e2a6ed422ef4153f5339d77 alpine-move-py-scripts-to-share.patch
+19cc2725d68db3e359e0e3016028374e5818a97fdba24d0103f7d1706601c8b17c4dd95a3152e64f982f98e95ad3e949acddbea8a39ed0ba8dd4f702acc2704d alpine-move-py-scripts-to-share.patch
8d6206f8c50856724cf7b4c1854ec82547f040358a1c7d44abeacc27a5c205a963b1fec51e58ec06c68d85bd2f68a9e6e27ebe457f39e8dd043de17758f5063f alpine-change-rpath-to-rustlib.patch
f230239d8de1b69536353e5735d3bf32f42a2715aefe4863622d9ab2b25d010209ed0bb38976eaa9302bce2eca6bd162abc8cefd71f689b65b3800920a50967b alpine-force-rpath-on-prefer-dynamic.patch
79549055dea81379c890b495c82456ab497a9179ec6702c59e11d0748bc668f47fc3d6a69c27a0545bb87c01318631dffc69260bf2d4badc75f53cbf7fad7528 check-rustc"
diff --git a/testing/rust/alpine-dont-require-filecheck.patch b/testing/rust/alpine-dont-require-filecheck.patch
deleted file mode 100644
index 6556d82a46..0000000000
--- a/testing/rust/alpine-dont-require-filecheck.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Thu, 06 Apr 2017 12:25:00 +0200
-Subject: [PATCH] Do not require FileCheck
-
---- a/src/bootstrap/sanity.rs
-+++ b/src/bootstrap/sanity.rs
-@@ -144,12 +144,6 @@
- }
- }
-
-- // Externally configured LLVM requires FileCheck to exist
-- let filecheck = build.llvm_filecheck(&build.config.build);
-- if !filecheck.starts_with(&build.out) && !filecheck.exists() && build.config.codegen_tests {
-- panic!("FileCheck executable {:?} does not exist", filecheck);
-- }
--
- for target in build.config.target.iter() {
- // Can't compile for iOS unless we're on OSX
- if target.contains("apple-ios") &&