aboutsummaryrefslogtreecommitdiffstats
path: root/testing/s-nail
diff options
context:
space:
mode:
authorSteffen (Daode) Nurpmeso <steffen@sdaoden.eu>2018-03-09 20:51:40 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-03-12 08:40:00 +0000
commit47c5ac1c7aa1fec8c641da76d1dc33192360f6eb (patch)
tree4a0bd500d5f59b6668a64daa9a0e99bf7cfb5bd1 /testing/s-nail
parentaa1451cd338713944975240130f4bc2b3c5c88f5 (diff)
downloadaports-47c5ac1c7aa1fec8c641da76d1dc33192360f6eb.tar.bz2
aports-47c5ac1c7aa1fec8c641da76d1dc33192360f6eb.tar.xz
testing/s-nail: fix invalid mem access, reenable tests, take maintainership..
The reported crash (for v14.9.9) does not happen in EVP_cleanup(), even though the instrumented code apparantly said so, but the actual cause was a memory access on an already freed pointer that sneaked into the release (which has not seen thorough testing, also apparantly).
Diffstat (limited to 'testing/s-nail')
-rw-r--r--testing/s-nail/APKBUILD15
-rw-r--r--testing/s-nail/fix-inv-mem-access.patch10
2 files changed, 20 insertions, 5 deletions
diff --git a/testing/s-nail/APKBUILD b/testing/s-nail/APKBUILD
index 1baa09c35e..ca56c20661 100644
--- a/testing/s-nail/APKBUILD
+++ b/testing/s-nail/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Steffen Nurpmeso <steffen@sdaoden.eu>
# Contributor: Ivan Tham <pickfire@riseup.net>
-# Maintainer: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Steffen Nurpmeso <steffen@sdaoden.eu>
pkgname=s-nail
pkgver=14.9.9
-pkgrel=0
+pkgrel=1
pkgdesc="SysV mail/BSD Mail/POSIX mailx: send and receive Internet mail"
url="https://www.sdaoden.eu/code.html#s-mailx"
arch="all"
license="BSD"
makedepends="libressl-dev libidn-dev ncurses-dev krb5-dev"
-options="suid !check"
+options="suid"
replaces="mailx"
subpackages="$pkgname-doc"
-source="https://ftp.sdaoden.eu/s-nail-$pkgver.tar.xz"
+source="https://ftp.sdaoden.eu/s-nail-$pkgver.tar.xz
+ fix-inv-mem-access.patch"
builddir="$srcdir/"$pkgname-$pkgver
# LD_LIBRARY_PATH is included via -rpath, so use system defaults only.
@@ -29,7 +30,9 @@ build() {
VAL_SID= VAL_MAILX=mail \
VAL_PREFIX=/usr \
VAL_SYSCONFDIR=/etc \
+ \
OPT_AUTOCC=no \
+ \
config &&
make build # XXX unite with config in v14.9.10
}
@@ -46,4 +49,6 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="f0004952f7189a2549e01489b600a10a36f1fa3ba0b6c6a871c4ee99d3d3d49e97ed5a8068fa1692b7fd91d2b243d05dbc5d61fe3f1dc2e9ba9187d9d31707c4 s-nail-14.9.9.tar.xz"
+sha512sums="f0004952f7189a2549e01489b600a10a36f1fa3ba0b6c6a871c4ee99d3d3d49e97ed5a8068fa1692b7fd91d2b243d05dbc5d61fe3f1dc2e9ba9187d9d31707c4 s-nail-14.9.9.tar.xz
+47639f0f013724040aa70a47180b5e286f4143d2ecef960c27eef43bcf5d8f60db8c7c1aedb4d158779b783f79409cbd7c5b703ed28666e8cf80eb4448f86125 fix-inv-mem-access.patch"
+
diff --git a/testing/s-nail/fix-inv-mem-access.patch b/testing/s-nail/fix-inv-mem-access.patch
new file mode 100644
index 0000000000..1ef30a719e
--- /dev/null
+++ b/testing/s-nail/fix-inv-mem-access.patch
@@ -0,0 +1,10 @@
+--- a/mime.c 2018-03-09 20:24:35.737754669 +0100
++++ b/mime.c 2018-03-09 20:24:39.107748465 +0100
+@@ -678,7 +678,6 @@ mime_write_tohdr_a(struct str *in, FILE
+ xin.l = PTR2SIZE(cp - lastcp);
+ if ((sz = a_mime__convhdra(&xin, f, colp, msh)) < 0)
+ goto jleave;
+- xin.s[xin.l] = '<';
+ lastcp = cp;
+ } else {
+ cp = lastcp;