aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sane/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-12-28 14:53:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-28 14:53:50 +0000
commita2eaad0c97d965c30493af59653c7324f589c076 (patch)
treef354f64dd274d25247de656b5d575b85fffcce1c /testing/sane/APKBUILD
parentee31520a3bc761d4be8de11ffda8a11ac2896023 (diff)
downloadaports-a2eaad0c97d965c30493af59653c7324f589c076.tar.bz2
aports-a2eaad0c97d965c30493af59653c7324f589c076.tar.xz
testing/sane: only build qcam backend on x86*
qcam requires ioperm, inb and outb, which only exists on x86*
Diffstat (limited to 'testing/sane/APKBUILD')
-rw-r--r--testing/sane/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/testing/sane/APKBUILD b/testing/sane/APKBUILD
index 161f61a6ae..6f8ed21d6e 100644
--- a/testing/sane/APKBUILD
+++ b/testing/sane/APKBUILD
@@ -20,9 +20,11 @@ _backends="abaton agfafocus apple artec artec_eplus48u as6e avision bh canon can
kvs1025 kvs20xx kvs40xx leo lexmark ma1509 magicolor matsushita microtek microtek2 mustek mustek_usb
mustek_usb2 nec net niash pie pieusb pixma plustek plustek_pp ricoh rts8891 s9036 sceptre sharp sm3600
sm3840 snapscan sp15c st400 stv680 tamarack teco1 teco2 teco3 test u12 umax umax_pp umax1220u xerox_mfp p5"
-if [ "$CARCH" != "armhf" ]; then
- _backends="$_backends qcam"
-fi
+
+case "$CARCH" in
+x86*) _backends="$_backends qcam";;
+esac
+
_pkgdesc_dell1600n_net="SANE backend for Dell 1600n that supports colour and monochrome scans over ethernet, usb not supported"
for _backend in $_backends; do
subpackages="$subpackages $pkgname-backend-$_backend:_backend"