aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sndio
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-21 16:56:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-21 16:56:52 +0000
commitabfb54c476f9e6e4251e82c54c6f810bc667f82f (patch)
tree9a07117883024540da5d56378aefe6dee23e7eaf /testing/sndio
parent616aa57a8f4ea22153ad6cf3e2c5e4acb147bfda (diff)
downloadaports-abfb54c476f9e6e4251e82c54c6f810bc667f82f.tar.bz2
aports-abfb54c476f9e6e4251e82c54c6f810bc667f82f.tar.xz
testing/sndio: new aport
Small audio and MIDI framework part of the OpenBSD project http://www.sndio.org/
Diffstat (limited to 'testing/sndio')
-rw-r--r--testing/sndio/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/sndio/APKBUILD b/testing/sndio/APKBUILD
new file mode 100644
index 0000000000..0d61772bd4
--- /dev/null
+++ b/testing/sndio/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sndio
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Small audio and MIDI framework part of the OpenBSD project"
+url="http://www.sndio.org/"
+arch="all"
+license="ISC"
+depends=""
+makedepends="alsa-lib-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://www.sndio.org/sndio-$pkgver.tar.gz"
+builddir="$srcdir/sndio-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="add0a9f79db0bf2198a431afc39a8a8a263da3a1892d8c8f15fccd4d46735045f149f1b44cba1f9adeae68f38958d222d96fb21b897e5c48f51ebb593bcced21 sndio-1.4.0.tar.gz"