aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tengine/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-05-20 19:12:25 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-05-25 14:14:17 +0300
commit014e1be84b35f87e3c09317b60e7db9c956309c4 (patch)
tree778048d457c61b213eb840e6dfee9b535ce8e6fd /testing/tengine/APKBUILD
parent372b72396936385e028df47644997e60cba71341 (diff)
downloadaports-014e1be84b35f87e3c09317b60e7db9c956309c4.tar.bz2
aports-014e1be84b35f87e3c09317b60e7db9c956309c4.tar.xz
testing/tengine: upgrade to 2.2.2, modernize, clarity license
Diffstat (limited to 'testing/tengine/APKBUILD')
-rw-r--r--testing/tengine/APKBUILD117
1 files changed, 62 insertions, 55 deletions
diff --git a/testing/tengine/APKBUILD b/testing/tengine/APKBUILD
index eee502c11b..033791653f 100644
--- a/testing/tengine/APKBUILD
+++ b/testing/tengine/APKBUILD
@@ -2,77 +2,84 @@
# Contributor: Jeff Bilyk <jbilyk@gmail.com>
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: Dennis Przytarski <dennis@przytarski.com>
-
pkgname=tengine
-pkgver=2.1.0
-pkgrel=5
-pkgdesc="lightweight HTTP and reverse proxy server"
-url="http://tengine.taobao.org/"
+pkgver=2.2.2
+pkgrel=0
+pkgdesc="Lightweight HTTP and reverse proxy server. It is based on the Nginx HTTP server and has many advanced features."
+url="https://tengine.taobao.org/"
arch="all"
-license="Custom"
+license="BSD-2-Clause"
+pkgusers="tengine"
+pkggroups="tengine www-data"
+options="!check" # Makefile test cmd does not work
+replaces="nginx"
+makedepends="linux-headers gd-dev geoip-dev libxml2-dev libxslt-dev
+ libressl-dev paxmark pcre-dev perl-dev pkgconf zlib-dev"
install="$pkgname.pre-install $pkgname.pre-upgrade"
-makedepends="pcre-dev libressl-dev zlib-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-openrc"
source="http://tengine.taobao.org/download/tengine-$pkgver.tar.gz
- ipv6.patch
- musl-crypt-fix.patch
-
tengine.initd
tengine.logrotate
"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --conf-path=/etc/$pkgname/$pkgname.conf \
- --error-log-path=/var/log/$pkgname/error.log \
- --pid-path=/var/run/$pkgname.pid \
- --lock-path=/var/run/$pkgname.lock \
+ cd "$builddir"
+ ./configure \
+ --prefix=/var/lib/$pkgname \
+ --sbin-path=/usr/sbin/$pkgname \
--dso-path=/usr/lib/$pkgname \
- --http-log-path=/var/log/$pkgname/access.log \
- --http-client-body-temp-path=/tmp/$pkgname/client-body \
- --http-proxy-temp-path=/tmp/$pkgname/proxy \
- --http-fastcgi-temp-path=/tmp/$pkgname/fastcgi \
- --user=tengine --group=tengine \
- --with-ipv6 \
- --with-http_ssl_module \
+ --conf-path=/etc/$pkgname/$pkgname.conf \
+ --pid-path=/run/$pkgname/$pkgname.pid \
+ --lock-path=/run/$pkgname/$pkgname.lock \
+ --http-client-body-temp-path=/var/tmp/$pkgname/client_body \
+ --http-proxy-temp-path=/var/tmp/$pkgname/proxy \
+ --http-fastcgi-temp-path=/var/tmp/$pkgname/fastcgi \
+ --http-uwsgi-temp-path=/var/tmp/$pkgname/uwsgi \
+ --http-scgi-temp-path=/var/tmp/$pkgname/scgi \
+ --with-perl_modules_path=/usr/lib/perl5/vendor_perl \
+ --user=$pkgusers \
+ --group=${pkggroups%% *} \
+ --with-file-aio \
+ --with-http_addition_module \
+ --with-http_auth_request_module \
+ --with-http_dav_module \
+ --with-http_degradation_module \
+ --with-http_flv_module \
+ --with-http_geoip_module \
+ --with-http_gunzip_module \
--with-http_gzip_static_module \
- --with-mail --with-mail_ssl_module \
- || return 1
- make || return 1
+ --with-http_image_filter_module \
+ --with-http_mp4_module \
+ --with-http_random_index_module \
+ --with-http_realip_module \
+ --with-http_secure_link_module \
+ --with-http_slice_module \
+ --with-http_ssl_module \
+ --with-http_stub_status_module \
+ --with-http_sub_module \
+ --with-http_perl_module \
+ --with-http_v2_module \
+ --with-http_xslt_module \
+ --with-ipv6 \
+ --with-mail \
+ --with-mail_ssl_module \
+ --with-pcre-jit \
+ --with-threads
+
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
- install -m644 -D "$srcdir"/$pkgname.logrotate "$pkgdir"/etc/logrotate.d/$pkgname || return 1
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.logrotate "$pkgdir"/etc/logrotate.d/$pkgname
- install -m644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
}
-md5sums="fb60c57c2610c6a356153613c485e4af tengine-2.1.0.tar.gz
-801a87f7f9d27f8ad85b41a78b4c4461 ipv6.patch
-3aeb488921109e60d02ed64d36790aeb musl-crypt-fix.patch
-3ee0398ba7324d13ac9df060ebb560ba tengine.initd
-3b44a6123ba048728164c3f7bed417a1 tengine.logrotate"
-sha256sums="6d98e217deb6676438f0704eb51736239e390624479fedb8c59ebf7a8a30e7b3 tengine-2.1.0.tar.gz
-a24ef5843ae0afa538b00c37eb7da7870f9d7f146f52a9668678f7296cf71d9b ipv6.patch
-8c398640bd379c1c6a2fafcd2b3848a72902e47924e8e2490b312c141eec5d70 musl-crypt-fix.patch
-95769c85363324b4c9311c01c1e61fa733c462e0d6877dc8770c76a427e7652b tengine.initd
-2439b551c1ceb97ab720c43d646401dd10b8f7c66dfb5c8d28bbc8497a238f51 tengine.logrotate"
-sha512sums="e3c4022eea24489d485e576e676a1cd9c343d4cd15fa0e98ef6d84bc38c944f5e8ff4afd4a734e4fb3f334dff6718a215db4fe6b2209723a731d29f25a19b249 tengine-2.1.0.tar.gz
-68d64a84568ec2df0366925ab282a05ebe21a85044b6c7844a47573cfd8cc8ed119cc772358bc3fff36e2d4fdf583a730592825f5f98632993ca86d1f8438d5f ipv6.patch
-21114c775e4bdd1f7b8b9abc143284945e96ed1d8c49904ddf918abad87b16253f918ba47976cd2df32f0fdb8a7dad399d4200e879db2da6cf93a28aab236a75 musl-crypt-fix.patch
-7919e169dc002316f276285954e28760ab742685fb523400ed44cffdeb769e74bee0de9dfca2f53f04e48b277e9cf0384f493967d220b383ae2671edbca4ac0a tengine.initd
+sha512sums="f77a048261eae88fe8bdf9e68c59dfa502c61f1d6413c1166f627fadddac9673991335683897c24e7600c6367f147757f4838a655ebf96029867aeb03c99e222 tengine-2.2.2.tar.gz
+3075188f052bf67b4079e78a8b0c56ede7cd8cee890031bf970e45fe8ebdc5739ef092de691108d78b8a111a07cfc98e7ff30234f6a8583db3c647e5fea7d109 tengine.initd
b0ad2fffe47210805ba09667dc40b09d30c7d1ff19fcb0fd4aa548355dcb992a2f9a7a9d3b0992a81e20eecbe37a91c3646b56324daf356c1d811e526fe663f3 tengine.logrotate"