aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thermald
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-08 22:01:00 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-08 22:01:00 +0000
commit932f2160cb45fa7059ac8e31ececa5938ad8c59d (patch)
tree128f4737fbc0d292d56e69941847cf38a6121eae /testing/thermald
parent9a201ed69d1aa45e84a636598fffb59805ec06b2 (diff)
downloadaports-932f2160cb45fa7059ac8e31ececa5938ad8c59d.tar.bz2
aports-932f2160cb45fa7059ac8e31ececa5938ad8c59d.tar.xz
testing/thermald: fix FTBFS on ppc64le
Currently musl on ppc64le does not define cpuid.h. Avoiding including and calling _cpuid.
Diffstat (limited to 'testing/thermald')
-rw-r--r--testing/thermald/APKBUILD10
-rw-r--r--testing/thermald/ppc64le.patch36
2 files changed, 40 insertions, 6 deletions
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
index f623265006..28d579aabf 100644
--- a/testing/thermald/APKBUILD
+++ b/testing/thermald/APKBUILD
@@ -12,7 +12,8 @@ depends=""
makedepends="autoconf automake libtool dbus-glib-dev libxml2-dev linux-headers"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/01org/$_pkgname/archive/v$pkgver.tar.gz
- thermald.initd"
+ thermald.initd
+ ppc64le.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -40,9 +41,6 @@ package() {
"$pkgdir"/etc/init.d/$pkgname || return 1
}
-md5sums="f7b63e691fb941c92e14ccfcb667b593 thermald-1.5.4.tar.gz
-a1e252054ecdc987cf641df912b9a220 thermald.initd"
-sha256sums="42f72fc32c84adcbb2ee6667645c2e1653cdc4f85963e6f72efd83517f7c29f0 thermald-1.5.4.tar.gz
-ec67b3bbdbdb2c65415b061594de7f7e757bea1c2de19f2022d4fac4aba1af26 thermald.initd"
sha512sums="c23b4aabc59f11fe93074459d8343f587275771268d9c71c871da6bb46d8533a46ab9ac0b495c22771d9064288872abfd3180e3bc92dbe5842cff53046e543d6 thermald-1.5.4.tar.gz
-c4872ff38e8001b753b12759bcd11364581b12ff710fa1eac21d769fd62cb4ba1a01bd0ba4adec7a72b71be094a425b803239a56296e8c111426e08eb9917c70 thermald.initd"
+c4872ff38e8001b753b12759bcd11364581b12ff710fa1eac21d769fd62cb4ba1a01bd0ba4adec7a72b71be094a425b803239a56296e8c111426e08eb9917c70 thermald.initd
+517d2c26dc5464c59e9c0cbea2bb1bcbe78cad87a26965cec8ec6d48a4b1bbb25c73bc5e772bbf0754e56222c8497d534b974b3a94c104bc4213be740aea9a5d ppc64le.patch"
diff --git a/testing/thermald/ppc64le.patch b/testing/thermald/ppc64le.patch
new file mode 100644
index 0000000000..76d5527b79
--- /dev/null
+++ b/testing/thermald/ppc64le.patch
@@ -0,0 +1,36 @@
+Author: Breno Leitao <breno.leitao@gmail.com>
+Date: Sat Apr 8 21:31:07 2017 +0000
+
+ Enable the build on ppc64le Currently musl on ppc64le does not define
+ cpuid.h. Avoiding calling it.
+
+ Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
+
+--- a/src/thd_engine.cpp.old
++++ b/src/thd_engine.cpp
+@@ -35,13 +35,15 @@
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/utsname.h>
+-#include <cpuid.h>
+ #include <locale>
+ #include "thd_engine.h"
+ #include "thd_cdev_therm_sys_fs.h"
+ #include "thd_zone_therm_sys_fs.h"
+ #include "thd_zone_dynamic.h"
+ #include "thd_cdev_gen_sysfs.h"
++#ifndef __powerpc__
++#include <cpuid.h>
++#endif
+
+ static void *cthd_engine_thread(void *arg);
+
+@@ -603,7 +605,7 @@
+ };
+
+ int cthd_engine::check_cpu_id() {
+-#ifndef ANDROID
++#if !defined(ANDROID) && !defined(__powerpc__)
+ // Copied from turbostat program
+ unsigned int ebx, ecx, edx, max_level;
+ unsigned int fms, family, model, stepping;