aboutsummaryrefslogtreecommitdiffstats
path: root/testing/totem
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/totem
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/totem')
-rw-r--r--testing/totem/APKBUILD48
-rw-r--r--testing/totem/totem.post-install11
-rw-r--r--testing/totem/totem.post-upgrade11
-rw-r--r--testing/totem/totem.pre-deinstall11
4 files changed, 0 insertions, 81 deletions
diff --git a/testing/totem/APKBUILD b/testing/totem/APKBUILD
deleted file mode 100644
index 8d723109cf..0000000000
--- a/testing/totem/APKBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=totem
-pkgver=2.32.0
-pkgrel=3
-pkgdesc="media player for gnome"
-url="http://projects.gnome.org/totem"
-arch="x86 x86_64"
-license="GPL"
-depends="gst-plugins-good gst-plugins-bad gst-plugins-ugly gst-plugins-base-gnome gst-plugins-good-gnome gst-ffmpeg"
-depends_dev="gtk+-dev gstreamer-dev gst-plugins-base-dev gconf-dev totem-pl-parser-dev libunique-dev python-dev libsm-dev libice-dev"
-makedepends="$depends_dev gnome-doc-utils intltool"
-install="$pkgname.pre-deinstall $pkgname.post-install $pkgname.post-upgrade"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-mozilla"
-source="ftp://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
-
-_builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --disable-scrollkeeper || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-mozilla() {
- pkgdesc="totem mozilla plugin"
-
- mkdir -p "$subpkgdir"/usr/lib/mozilla
- mv "$pkgdir"/usr/lib/mozilla/plugins "$subpkgdir"/usr/lib/mozilla/plugins
-}
-
-md5sums="2e55c3da316648ba860e3f88af2d30ab totem-2.32.0.tar.bz2"
diff --git a/testing/totem/totem.post-install b/testing/totem/totem.post-install
deleted file mode 100644
index 87148a8ef8..0000000000
--- a/testing/totem/totem.post-install
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-for i in \
- totem.schemas \
- totem-handlers.schemas \
- totem-video-thumbnail.schemas \
-; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
-done
diff --git a/testing/totem/totem.post-upgrade b/testing/totem/totem.post-upgrade
deleted file mode 100644
index 87148a8ef8..0000000000
--- a/testing/totem/totem.post-upgrade
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-for i in \
- totem.schemas \
- totem-handlers.schemas \
- totem-video-thumbnail.schemas \
-; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
-done
diff --git a/testing/totem/totem.pre-deinstall b/testing/totem/totem.pre-deinstall
deleted file mode 100644
index c495189c7c..0000000000
--- a/testing/totem/totem.pre-deinstall
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-for i in \
- totem.schemas \
- totem-handlers.schemas \
- totem-video-thumbnail.schemas \
-; do
- echo "Uninstalling GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
-done