aboutsummaryrefslogtreecommitdiffstats
path: root/testing/uboot-tools
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-06-29 13:25:56 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-06-29 13:26:05 +0200
commit4aaacbd4b313d8b8e06397170f6d7f278710a11b (patch)
treea17be4230e0ba7b648026e6ca2bedb0db0e39bb8 /testing/uboot-tools
parent92181c3d3989bd6b81a61d5a71fa786b0e756fca (diff)
downloadaports-4aaacbd4b313d8b8e06397170f6d7f278710a11b.tar.bz2
aports-4aaacbd4b313d8b8e06397170f6d7f278710a11b.tar.xz
testing/uboot-tools: add fw_printenv and fw_setenv
Diffstat (limited to 'testing/uboot-tools')
-rw-r--r--testing/uboot-tools/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/uboot-tools/APKBUILD b/testing/uboot-tools/APKBUILD
index 8c27e61561..c06db25ea7 100644
--- a/testing/uboot-tools/APKBUILD
+++ b/testing/uboot-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=uboot-tools
pkgver=2016.05
-pkgrel=0
+pkgrel=1
pkgdesc="U-Boot bootloader utility tools"
url="http://www.denx.de/wiki/U-Boot/WebHome"
arch="all"
@@ -25,10 +25,14 @@ package() {
cd "$builddir"
for tool in bmp_logo dumpimage easylogo/easylogo env/fw_printenv \
fit_check_sign fit_info gdb/gdbcont gdb/gdbsend gen_eth_addr img2srec \
- mkenvimage mkimage ncb proftool ubsha1 xway-swap-bytes; do
+ mkenvimage mkimage ncb proftool ubsha1 xway-swap-bytes env/fw_printenv; do
install -D tools/$tool \
$pkgdir/usr/bin/$(basename $tool) || return 1
done
+ install -Dm644 tools/env/fw_env.config \
+ $pkgdir/etc/fw_env.config || return 1
+ cd "$pkgdir"/usr/bin
+ ln -sf fw_printenv fw_setenv || return 1
}
md5sums="3a8613d753dfa707c937991a35404510 u-boot-2016.05.tar.bz2"