aboutsummaryrefslogtreecommitdiffstats
path: root/testing/udpcast
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-04-12 14:32:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-12 14:32:14 +0000
commita5edbe75dbbb739182f49c4b6727db3fd21083ba (patch)
treea87e6448667ab3cd7e9d910da3002001c7be4be0 /testing/udpcast
parentaddd7bac86749f75d20d5b431774d3c84e23bb94 (diff)
downloadaports-a5edbe75dbbb739182f49c4b6727db3fd21083ba.tar.bz2
aports-a5edbe75dbbb739182f49c4b6727db3fd21083ba.tar.xz
testing/udpcast: build fix
Diffstat (limited to 'testing/udpcast')
-rw-r--r--testing/udpcast/APKBUILD36
-rw-r--r--testing/udpcast/console.patch (renamed from testing/udpcast/patch/console.patch)4
2 files changed, 17 insertions, 23 deletions
diff --git a/testing/udpcast/APKBUILD b/testing/udpcast/APKBUILD
index 05f6ab84da..90bbdc305f 100644
--- a/testing/udpcast/APKBUILD
+++ b/testing/udpcast/APKBUILD
@@ -7,37 +7,31 @@ pkgdesc="Port of UDPcast file transfer tool"
url="https://www.udpcast.linux.lu/index.html"
arch="all"
license="GPL2"
-depends="musl"
+depends=""
depends_dev=""
-makedepends="$depends_dev"
+makedepends="$depends_dev linux-headers m4 perl"
install=""
-subpackages="$pkgname-doc"
-source="https://www.udpcast.linux.lu/download/udpcast-20120424.tar.gz"
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://www.udpcast.linux.lu/download/udpcast-$pkgver.tar.gz
+ console.patch
+ "
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
- patch -p0 < ../../patch/console.patch
+ cd "$builddir"
./configure --prefix=/usr || return 1
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-
-md5sums="b9b67a577ca5659a93bcb9e43f298fb2 udpcast-20120424.tar.gz"
-sha256sums="ce9090ef80b6035a744a9b5ac335e61c99baa92c39ff53277266fbfcb836445a udpcast-20120424.tar.gz"
-sha512sums="b16a1d3215cbefba1e4d6bb0b38f4715e476c41ddc93fa1a38c5e707af786f4a97badd1eea494f7838f276f370af414d8379db04a14b9b3ff32a1318f16db33d udpcast-20120424.tar.gz"
+md5sums="b9b67a577ca5659a93bcb9e43f298fb2 udpcast-20120424.tar.gz
+ec69737cfb30c87265eabfec8c7abe04 console.patch"
+sha256sums="ce9090ef80b6035a744a9b5ac335e61c99baa92c39ff53277266fbfcb836445a udpcast-20120424.tar.gz
+56112c12c0bd74c0844ff33f73a943dca31fbb9cd9859e842f169a969ea99d1e console.patch"
+sha512sums="b16a1d3215cbefba1e4d6bb0b38f4715e476c41ddc93fa1a38c5e707af786f4a97badd1eea494f7838f276f370af414d8379db04a14b9b3ff32a1318f16db33d udpcast-20120424.tar.gz
+7abfcf317b5985f680258abc913a48cfd21a26f77625780e57d93960f7efeb0f214ce4d4188bd75cedb9dccac5a5fe9befed2044e3df3b0e8228ac6e0663c41c console.patch"
diff --git a/testing/udpcast/patch/console.patch b/testing/udpcast/console.patch
index 8cb7d0768e..71cd0c081a 100644
--- a/testing/udpcast/patch/console.patch
+++ b/testing/udpcast/console.patch
@@ -1,5 +1,5 @@
---- console.c
-+++ console.c.new
+--- a/console.c
++++ b/console.c
@@ -3,6 +3,7 @@
#include <stdio.h>
#include <errno.h>