aboutsummaryrefslogtreecommitdiffstats
path: root/testing/uhttpmock/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
commita39e19f96447a409ae6f6c1c63d3c16feb1a3991 (patch)
tree148fdebc95bfd8788f91996703d2094c1b8df4da /testing/uhttpmock/APKBUILD
parentc5240dc4d2a5efc26b94c943d87848e51ba2794b (diff)
downloadaports-a39e19f96447a409ae6f6c1c63d3c16feb1a3991.tar.bz2
aports-a39e19f96447a409ae6f6c1c63d3c16feb1a3991.tar.xz
unmaintained/[multiple] move back packages to testing
move back packages that are depends of other packages in testing
Diffstat (limited to 'testing/uhttpmock/APKBUILD')
-rw-r--r--testing/uhttpmock/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/uhttpmock/APKBUILD b/testing/uhttpmock/APKBUILD
new file mode 100644
index 0000000000..5cf165bd89
--- /dev/null
+++ b/testing/uhttpmock/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=uhttpmock
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="HTTP web service mocking library"
+url="http://gitorious.org/uhttpmock/"
+arch="all"
+license="LGPLv2"
+depends=""
+depends_dev="libsoup-dev glib-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://tecnocode.co.uk/downloads/uhttpmock/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir"/uhttpmock-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ebc54cbbe9b6695282a179af223fe374 uhttpmock-0.5.0.tar.xz"
+sha256sums="26da182a2db2579c5ba4dad9096d52099e0766228c295cfbaed6de4046f7d16e uhttpmock-0.5.0.tar.xz"
+sha512sums="952b618f3a12d7190f3812bc0bd53dd655a83d27f29bb749e62b36a08492bf535b85db7f5ff66f15c72bf5574696149f00476041f225ca6039ad87b221f5a1c6 uhttpmock-0.5.0.tar.xz"