aboutsummaryrefslogtreecommitdiffstats
path: root/testing/unit/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-07 18:56:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-07 18:56:25 +0200
commitcf74b3cfd311bb589ae69e6886f95bb18b482744 (patch)
tree22567909207b02905236cf3b16a1501bc0f2fc69 /testing/unit/APKBUILD
parent6e34e3ebd65921fcc0ccb3135e81c4271b070f95 (diff)
downloadaports-cf74b3cfd311bb589ae69e6886f95bb18b482744.tar.bz2
aports-cf74b3cfd311bb589ae69e6886f95bb18b482744.tar.xz
community/unit: move from testing
Diffstat (limited to 'testing/unit/APKBUILD')
-rw-r--r--testing/unit/APKBUILD90
1 files changed, 0 insertions, 90 deletions
diff --git a/testing/unit/APKBUILD b/testing/unit/APKBUILD
deleted file mode 100644
index 05c7de4cda..0000000000
--- a/testing/unit/APKBUILD
+++ /dev/null
@@ -1,90 +0,0 @@
-# Contributor: André Klitzing <aklitzing@gmail.com>
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: André Klitzing <aklitzing@gmail.com>
-pkgname=unit
-pkgver=1.1
-pkgrel=0
-pkgdesc="NGINX Unit is a dynamic web application server"
-url="https://unit.nginx.org/"
-# armhf, x86: tests fail (https://github.com/nginx/unit/issues/118)
-arch="all !armhf !x86"
-license="Apache-2.0"
-_phpver=7
-makedepends="perl-dev php$_phpver-dev php$_phpver-embed python3-dev ruby-dev"
-install="$pkgname.pre-install"
-subpackages="$pkgname-openrc"
-source="https://unit.nginx.org/download/$pkgname-$pkgver.tar.gz
- $pkgname.initd
- $pkgname.confd
- $pkgname.logrotate"
-builddir="$srcdir/$pkgname-$pkgver"
-
-for _mod in perl php$_phpver python3 ruby; do
- subpackages="$subpackages $pkgname-$_mod:_module"
-done
-
-_modules_dir="/usr/lib/unit/modules"
-
-build() {
- cd "$builddir"
-
- # Needed for building perl module.
- export CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
-
- ./configure \
- --prefix="/usr" \
- --state="/var/lib/unit" \
- --control="unix:/run/control.unit.sock" \
- --pid="/run/unit.pid" \
- --log="/var/log/unit.log" \
- --modules="$_modules_dir" \
- --user=unit \
- --group=unit \
- --tests
- ./configure perl
- ./configure php --module=php$_phpver --config=php-config$_phpver
- ./configure python --config=python3-config
- ./configure ruby
-
- make
- make tests
-}
-
-check() {
- cd "$builddir"
-
- ./build/tests
-
- # FIXME: Some tests are broken.
- #make install DESTDIR=".dest"
- #./test/run.py
-}
-
-package() {
- cd "$builddir"
-
- make unitd-install DESTDIR="$pkgdir"
-
- install -D -m 755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -D -m 644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
- install -D -m 644 "$srcdir"/$pkgname.logrotate "$pkgdir"/etc/logrotate.d/$pkgname
-}
-
-openrc() {
- default_openrc
- depends="curl"
-}
-
-_module() {
- local modname=${subpkgname#$pkgname-}
- pkgdesc="$modname module for NGINX Unit"
- depends="$pkgname=$pkgver-r$pkgrel"
-
- cd "$builddir"
- make $modname-install DESTDIR="$subpkgdir"
-}
-
-sha512sums="89460e96d775df7f0c9d66011b59ca45ebe99e1e9e194f1800824ee1a3ae9c3f0207c9c749d34c250560ded6f1c3ad5b66fadcb3ffb2c62c5a6f5115944cea1f unit-1.1.tar.gz
-a835b83284d7bd4afb445dd93c84e2c6dd5906f137784ff3189edc82c3f14f07c5de00681125924138e3ac420cc849cc93e52cabbd6b550ded09d055d30e091c unit.initd
-f85112726dfcace2b6d94b10669615fef517f5aa10ac858890dd9f5c868a6e2569500f7411f758fcb24c98c9630760d36a74bd33ea510ab0f8ca8cd6cb1fb1e8 unit.confd
-723e465162dfdb31881680200221542add414e54ef4f4f1fc57e91b7b57777dfb21c2eee4727ecbba0c1943bb77a2597cc0225b16e334c38258c296d15b1df74 unit.logrotate"