aboutsummaryrefslogtreecommitdiffstats
path: root/testing/upmpdcli/APKBUILD
diff options
context:
space:
mode:
authorMarvin Steadfast <marvin@xsteadfastx.org>2017-08-25 08:42:38 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-25 23:19:22 +0000
commitcff5678b347f584fa03404d018e877b1d71b6cea (patch)
tree4ed5ef00eb29697532618a64d34dea099c03b319 /testing/upmpdcli/APKBUILD
parentc387838a5c5c593075fe3e16850e2f5aacb84875 (diff)
downloadaports-cff5678b347f584fa03404d018e877b1d71b6cea.tar.bz2
aports-cff5678b347f584fa03404d018e877b1d71b6cea.tar.xz
testing/upmpdcli: new package
Diffstat (limited to 'testing/upmpdcli/APKBUILD')
-rw-r--r--testing/upmpdcli/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/upmpdcli/APKBUILD b/testing/upmpdcli/APKBUILD
new file mode 100644
index 0000000000..49dc80844b
--- /dev/null
+++ b/testing/upmpdcli/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marvin Steadfast <marvin@xsteadfastx.org>
+# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
+pkgname=upmpdcli
+pkgver=1.2.15
+pkgrel=0
+pkgdesc="upmpdcli is a UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+url="http://www.lesbonscomptes.com/upmpdcli"
+arch="all"
+license="GPL2"
+options="!check"
+depends=""
+makedepends="libupnpp-dev libmpdclient-dev libmicrohttpd-dev jsoncpp-dev"
+install=""
+subpackages="$pkgname-doc"
+source="upmpdcli-$pkgver.tar.gz::http://www.lesbonscomptes.com/upmpdcli/downloads/upmpdcli-$pkgver.tar.gz"
+builddir="$srcdir/upmpdcli-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4a62aced9fa2395752164332c84bf3dedd7b793e7e37638cfe063e887d52b9ce956c866de2aa1cddb7a4dcad97562050f9588aedd59e49e7d427671179f9258a upmpdcli-1.2.15.tar.gz"