aboutsummaryrefslogtreecommitdiffstats
path: root/testing/w_scan
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-30 09:08:27 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-30 09:08:27 +0000
commit9582332f5244fd47f63334263f3a60376719b415 (patch)
tree0f7c8ca4bc84b71c007259e096ea9a58d6b25305 /testing/w_scan
parentba34785b08985b07025a3d0e93479656bfe284c7 (diff)
downloadaports-9582332f5244fd47f63334263f3a60376719b415.tar.bz2
aports-9582332f5244fd47f63334263f3a60376719b415.tar.xz
testing/w_scan: new aport
Diffstat (limited to 'testing/w_scan')
-rw-r--r--testing/w_scan/APKBUILD36
-rw-r--r--testing/w_scan/musl-build-time-h-fix.patch12
-rw-r--r--testing/w_scan/musl-build-uint-fix.patch12
3 files changed, 60 insertions, 0 deletions
diff --git a/testing/w_scan/APKBUILD b/testing/w_scan/APKBUILD
new file mode 100644
index 0000000000..42fd2970d1
--- /dev/null
+++ b/testing/w_scan/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=w_scan
+pkgver=20161022
+pkgrel=0
+pkgdesc="Universal ATSC and DVB blind scanner"
+url="http://wirbel.htpc-forum.de/w_scan/index_en.html"
+arch="all"
+license="GPL"
+makedepends="linux-headers"
+subpackages="$pkgname-doc"
+source="http://wirbel.htpc-forum.de/$pkgname/$pkgname-$pkgver.tar.bz2
+musl-build-time-h-fix.patch
+musl-build-uint-fix.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="57aa860b4c9e6aa480ca6eb0504bd4f5 w_scan-20161022.tar.bz2
+79d2970d162d91c9f0392e74725326fe musl-build-time-h-fix.patch
+633b01139ff767da94afa93bc3d386f8 musl-build-uint-fix.patch"
+sha256sums="2077af7f8b42b7af038e83abf0565f96f59461bbc5e14c4516b68f50b5c00d79 w_scan-20161022.tar.bz2
+09ea1ab87568682c71b047a75aa9f347e3c739eae5875db2142d706f9ba72d73 musl-build-time-h-fix.patch
+b2aa3ce57d88628d46febc6fcd66473fc6f58c8ffc47f13c7b22ad140051e4ff musl-build-uint-fix.patch"
+sha512sums="f0f91a0115612c03f4e3de536b416f32ce8242df9db7e65bd3f673973e5e00bbc763edfb27b286eaa44bef052fc3aaf8fbb1312b8dd103f0ff72f3417c33b042 w_scan-20161022.tar.bz2
+5514dd105c51b23728ea4d5d0e04604b2674e0686645b1434197a9cdaa98bf7cac3946baad6357478160ce1feb5d1a3a74b8c1897f846cfb04c0bb58d9ac8b1b musl-build-time-h-fix.patch
+eeaa1fb1961ece503582f5f3a81edbc0a131f49ce5f78e0a1119fff067338f3ba5052acbba2c54254be242a1ebd19a9ae0cea5c35da93727f53350a4f4a74008 musl-build-uint-fix.patch"
diff --git a/testing/w_scan/musl-build-time-h-fix.patch b/testing/w_scan/musl-build-time-h-fix.patch
new file mode 100644
index 0000000000..d07b026ca4
--- /dev/null
+++ b/testing/w_scan/musl-build-time-h-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/descriptors.h b/descriptors.h
+index bb45e6e..3ee0b8b 100644
+--- a/descriptors.h
++++ b/descriptors.h
+@@ -29,6 +29,7 @@
+ #define __DESCRIPTORS_H__
+
+ #include "extended_frontend.h"
++#include "time.h"
+
+ /******************************************************************************
+ * descriptor ids as defined by standards.
diff --git a/testing/w_scan/musl-build-uint-fix.patch b/testing/w_scan/musl-build-uint-fix.patch
new file mode 100644
index 0000000000..51b82cc027
--- /dev/null
+++ b/testing/w_scan/musl-build-uint-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/version.h b/version.h
+index 16661b5..44c5ec7 100644
+--- a/version.h
++++ b/version.h
+@@ -1,6 +1,6 @@
+ /* AUTOMATICALLY GENERATED - DO NOT EDIT MANUALLY */
+ #ifndef W_SCAN_VERSION_H
+ #define W_SCAN_VERSION_H
+-uint version=20161022;
++unsigned int version=20161022;
+ #endif
+