aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wireguard-hardened/APKBUILD
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-05-18 20:57:07 +0200
committerShiz <hi@shiz.me>2017-05-18 20:57:07 +0200
commit162b2e6e96b4280079e9176405770888f3a53052 (patch)
tree24ba595863197adf1f27659b622cce06cc499e8b /testing/wireguard-hardened/APKBUILD
parentf87448aef4ca24684213f00152212694d7da31ee (diff)
downloadaports-162b2e6e96b4280079e9176405770888f3a53052.tar.bz2
aports-162b2e6e96b4280079e9176405770888f3a53052.tar.xz
testing/wireguard: fix install_if rule and bump _mypkgrel
Diffstat (limited to 'testing/wireguard-hardened/APKBUILD')
-rw-r--r--testing/wireguard-hardened/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/wireguard-hardened/APKBUILD b/testing/wireguard-hardened/APKBUILD
index 37e53277ea..d3c08749dc 100644
--- a/testing/wireguard-hardened/APKBUILD
+++ b/testing/wireguard-hardened/APKBUILD
@@ -7,8 +7,10 @@ _kver=4.9.28
_kpkgrel=1
# when changing _ver we *must* bump _mypkgrel
+# we must also match up _toolsrel with wireguard-tools
_ver=0.0.20170517
-_mypkgrel=0
+_mypkgrel=1
+_toolsrel=0
_name=wireguard
# verify the kernel version before entering chroot
@@ -21,6 +23,7 @@ if [ -f $_kapkbuild ]; then
fi
_kpkgver="$_kver-r$_kpkgrel"
+_toolsver="$_ver-r$_toolsrel"
_abi_release=${_kver}-${_kpkgrel}-${_flavor}
pkgname=${_name}-${_flavor}
@@ -32,7 +35,7 @@ url='https://www.wireguard.io'
license="GPLv2"
depends="linux-${_flavor}=${_kpkgver}"
makedepends="linux-${_flavor}-dev=$_kpkgver libmnl-dev"
-install_if="wireguard-tools linux-grsec-$_kpkgver"
+install_if="wireguard-tools=$_toolsver linux-hardened=$_kpkgver"
options="!check"
source="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-$_ver.tar.xz"
provides="${_name}-grsec=${_kver}-r${pkgrel}"