aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wmi-client/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-01-23 10:02:43 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-01-23 10:30:00 +0000
commitcbbbaf9ebace0d597f0a0e210344a2a5cabb7417 (patch)
tree967156aabdd72939c094b13922ef40fb9b4d0203 /testing/wmi-client/APKBUILD
parent9ce2e6769410a7e04c13f2a5145f2e343ce3085e (diff)
downloadaports-cbbbaf9ebace0d597f0a0e210344a2a5cabb7417.tar.bz2
aports-cbbbaf9ebace0d597f0a0e210344a2a5cabb7417.tar.xz
testing/wmi-client: new aport
Diffstat (limited to 'testing/wmi-client/APKBUILD')
-rw-r--r--testing/wmi-client/APKBUILD69
1 files changed, 69 insertions, 0 deletions
diff --git a/testing/wmi-client/APKBUILD b/testing/wmi-client/APKBUILD
new file mode 100644
index 0000000000..51ff15cb2f
--- /dev/null
+++ b/testing/wmi-client/APKBUILD
@@ -0,0 +1,69 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=wmi-client
+_pkgname="${pkgname/-*/}"
+pkgver=1.3.16
+pkgrel=0
+pkgdesc="DCOM/WMI client implementation"
+url="https://www.orvant.com/packages"
+arch="all !aarch64"
+license="GPL3"
+subpackages="libwmiclient-dev:libdev libwmiclient:lib"
+makedepends="autoconf python-dev perl-datetime"
+source="https://launchpad.net/~cybersec/+archive/ubuntu/chaos-ppa-v2/+files/${_pkgname}_${pkgver}.orig.tar.bz2
+ openvas-wmi-1.3.14.patch
+ samba-pidl.patch
+ pyinclude.patch
+ perl-support.patch
+ musl-header-fix.patch
+ gnumakefile.patch"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make build "CPP=gcc -E -ffreestanding"
+}
+
+package() {
+ cd "$builddir"
+ cd Samba/source
+ mkdir -p "$pkgdir"/usr/lib
+ local _bins="wmic winexe"
+ for bins in $_bins; do
+ install -Dm755 bin/$bins "$pkgdir"/usr/bin/$bins
+ done
+ sh ./install-libwmiclient.sh "$pkgdir"/usr
+}
+
+libdev() {
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/pkgconfig "$subpkgdir"/usr/lib
+}
+
+lib() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/lib "$subpkgdir"/usr
+}
+
+md5sums="ba0ebcc3d5b25cb3690672f845ce3003 wmi_1.3.16.orig.tar.bz2
+4b5b32a46e7851ef20779f85c27971b6 openvas-wmi-1.3.14.patch
+9de58f9dc808e8efc6753f8c9004fdff samba-pidl.patch
+c1d6acdb9f21384ea7743da0a44712a8 pyinclude.patch
+67fe2896a770bb2659bd8578393ffaa2 perl-support.patch
+05914b6c0255639c8d13269bb318e547 musl-header-fix.patch
+eab5bfe1731480ef97b9457769b9129f gnumakefile.patch"
+sha256sums="1001e0786485ba70ec5ae94b205b182f9cda50cb305d31d12c0ca2edd4c39aff wmi_1.3.16.orig.tar.bz2
+461bb9af6f0fa55e6a010a0f2f576c479d6160f49ed7e9072009fff9ea54e458 openvas-wmi-1.3.14.patch
+871af9b2a952bf8b3596ecd751dabe0bce6059e46548a211708eaee4e952382e samba-pidl.patch
+4f281f6eae370a8ec91caab53c6f682d6a000d816a86625d866c886dc27bd56d pyinclude.patch
+5235980b4a5f4dd45a03c4ef941c6d8bf9636bb9f68c892caba2c1b09317e666 perl-support.patch
+acfad8ed9a5607227a12ac814e10697fbc8695d856ce2a75e8a9e490d68e1147 musl-header-fix.patch
+dc3d4e30897954f3b90c5861258c056a5625d1609dde1663ad1709e85f69df15 gnumakefile.patch"
+sha512sums="cd5ccf23dff59dd599ae23b4cd8d0d68f42775b2afad8e05add04d0d4054cbb8e33655323b1d87795f23a71b6c0c0e260e38f53349c77618d2421862d172a508 wmi_1.3.16.orig.tar.bz2
+af97edd7d37864cddcd02c9f66beb940058138964113f2687dc5a3d62a0b0b60524a9ba7f5ecdc8b1d4f99b2fd2805086d9953556b77e8b78891e74694735293 openvas-wmi-1.3.14.patch
+cc0bbeb6805bb38898ced7956ed313c6cf67c11316eb2906a353fc227d1dc538fc8ce689035fee865f42e7bd13d4f74b5f12b925399f64cb22ea110da4ae9f9a samba-pidl.patch
+5d2073fe0313e92c10fdaee7fd65d2d26e1a2ac1ec70955b2009c8aaad33a4944a2a8f354d416ac346cc0c43b04b1ffe95ee012cd77ddb74a7459d67f44aec4b pyinclude.patch
+74f1172cf3d5297ea9be473acf0fcdaeb3e199b9922054eea427999ab571400c1817f3734a385d9c85f4dfad3a85e57ff1970df2c023e972fb6985dec8a9dbae perl-support.patch
+bf85fbd199398c10e389fda03a6d791633c0ebc798af5ecfe66f9d5ec519b01bd0518e42da6cf88d8d47bce196bb1ce2a561c8a77e6fca8e99f38552b7a47459 musl-header-fix.patch
+afb2713a33d73c51cf4444be53e909cfa86f930dce317d4f8047fc15ad2ec2b2f8835a8cc231cd9450ffe11439483fe095f9b48ce4426cdcfbc6db3c314c11f7 gnumakefile.patch"