aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xclip
diff options
context:
space:
mode:
authorsystmkor <systmkor@gmail.com>2015-01-01 02:40:30 -0800
committerNatanael Copa <ncopa@alpinelinux.org>2015-01-01 15:57:51 +0000
commit398d0e5a0c6a3260d1250d7e671b4adcc79c72c7 (patch)
tree370abd6e3482dd0d3f7d39cb8ab8dd0646b822d9 /testing/xclip
parent7e3d630497331bd8e55970a344502623c070d169 (diff)
downloadaports-398d0e5a0c6a3260d1250d7e671b4adcc79c72c7.tar.bz2
aports-398d0e5a0c6a3260d1250d7e671b4adcc79c72c7.tar.xz
testing/xclip: new aport
Command line interface to the X11 clipboard http://sourceforge.net/projects/xclip
Diffstat (limited to 'testing/xclip')
-rw-r--r--testing/xclip/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/xclip/APKBUILD b/testing/xclip/APKBUILD
new file mode 100644
index 0000000000..96038a94f6
--- /dev/null
+++ b/testing/xclip/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Orion <systmkor@gmail.com>
+# Maintainer: Orion <systmkor@gmail.com>
+# Reference
+# https://www.archlinux.org/packages/extra/x86_64/xclip/
+pkgname=xclip
+pkgver=0.12
+pkgrel=0
+pkgdesc="Command line interface to the X11 clipboard"
+url="http://sourceforge.net/projects/xclip"
+arch="x86 x86_64"
+license="GPL2"
+depends="libxmu"
+depends_dev="libxmu-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/xclip/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="f7e19d3e976fecdc1ea36cd39e39900d xclip-0.12.tar.gz"
+sha256sums="b7c7fad059ba446df5692d175c2a1d3816e542549661224806db369a0d716c45 xclip-0.12.tar.gz"
+sha512sums="6c769878004c02d87b9eca2b33dc34edb40acc59be767a6481f207a74d52fca3725a040b0c8deffa1419b687bd73cf3124a090413c06787c0dd137b0ede795e0 xclip-0.12.tar.gz"