aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xdesktop
diff options
context:
space:
mode:
authoronodera@openmailbox.org <onodera@openmailbox.org>2016-04-15 19:20:03 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-18 16:05:09 +0000
commit7e2cc0cfa82716816af4263feea24424f7c9bd8f (patch)
treea24372943ed805eca68b2c5928a7c8ce9e7daf21 /testing/xdesktop
parent0f7390d839badcd04e9e8c21bb8cde1af7dc074e (diff)
downloadaports-7e2cc0cfa82716816af4263feea24424f7c9bd8f.tar.bz2
aports-7e2cc0cfa82716816af4263feea24424f7c9bd8f.tar.xz
testing/xdesktop: new aport
https://github.com/onodera-punpun/xdesktop outputs and changes X virtual desktop
Diffstat (limited to 'testing/xdesktop')
-rw-r--r--testing/xdesktop/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/xdesktop/APKBUILD b/testing/xdesktop/APKBUILD
new file mode 100644
index 0000000000..45e675723b
--- /dev/null
+++ b/testing/xdesktop/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Camille Scholtz <onodera@openmailbox.org>
+# Maintainer: Camille Scholtz <onodera@openmailbox.org>
+pkgname=xdesktop
+pkgver=0.3
+pkgrel=0
+pkgdesc="output and change X virtual desktop"
+url="https://github.com/onodera-punpun/xdesktop"
+arch="all"
+license="unlicense"
+depends=""
+depends_dev="xcb-util-wm-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="saveas-https://github.com/onodera-punpun/$pkgname/archive/$pkgver.tar.gz/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fbc59a158d93dcee518bd6298a2c3530 xdesktop-0.3.tar.gz"
+sha256sums="b2c9cd6aaae3b13c4fd8f61799b12454387be838df9078db6faf14dbfaef01ca xdesktop-0.3.tar.gz"
+sha512sums="125d880c0d2af5c847b74caf5fc51f32d597dc00f25dc334fa5a2664438b248da5989d3f4df2bbd7c5998511cdcf2144625ebc0653ad481dd88378551a7ae529 xdesktop-0.3.tar.gz"