aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xfce4-sensors-plugin
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-04-09 23:21:12 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-04-09 23:21:12 +0200
commitc9d2af8d1692ac566274cc369043becbaf1dab9b (patch)
tree92c305f226bab89544b74d23205290f6a34b94a7 /testing/xfce4-sensors-plugin
parent568316df90a20e57f3b5e9ca29b4723c9c223468 (diff)
downloadaports-c9d2af8d1692ac566274cc369043becbaf1dab9b.tar.bz2
aports-c9d2af8d1692ac566274cc369043becbaf1dab9b.tar.xz
testing/xfce4-sensors-plugin: new aport
Diffstat (limited to 'testing/xfce4-sensors-plugin')
-rw-r--r--testing/xfce4-sensors-plugin/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/xfce4-sensors-plugin/APKBUILD b/testing/xfce4-sensors-plugin/APKBUILD
new file mode 100644
index 0000000000..b14d3efa3b
--- /dev/null
+++ b/testing/xfce4-sensors-plugin/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=xfce4-sensors-plugin
+pkgver=1.2.6
+pkgrel=0
+pkgdesc="Reads your hardware sensor values and displays them in your panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev="xfce4-panel-dev lm_sensors-dev libxfce4ui-dev"
+makedepends="$depends_dev bash"
+install=""
+subpackages="$pkgname-dev $pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/$pkgname/1.2/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xfce4-sensors-plugin-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="33c2e343c1224d9c4ae757a70cbe08eb xfce4-sensors-plugin-1.2.6.tar.bz2"
+sha256sums="235ef842bd45e701bceebb21a384ab09f21afceea8ed95f91bb4c6cf3abe1bc0 xfce4-sensors-plugin-1.2.6.tar.bz2"
+sha512sums="5c520f1c253df1bb9e29855c5ccfc1536034945ca68b43cd8b6d97083e528b2430230d9c51d43953a71c3f0171ae718bf1557714729b1343ebd51f91f3f36d60 xfce4-sensors-plugin-1.2.6.tar.bz2"