aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xvidtune
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 17:06:47 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 17:06:54 +0000
commitb7f1ad0466d29412d00b9c2aa4281ed852b83fde (patch)
tree4976f496e13dc59469a434940ee4c608911381e3 /testing/xvidtune
parenta6686e6e788eabf5d8fb6275c4460f46784450d2 (diff)
downloadaports-b7f1ad0466d29412d00b9c2aa4281ed852b83fde.tar.bz2
aports-b7f1ad0466d29412d00b9c2aa4281ed852b83fde.tar.xz
testing/xvidtune: update config.guess and config.sub to fix build on aarch64
Diffstat (limited to 'testing/xvidtune')
-rw-r--r--testing/xvidtune/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/xvidtune/APKBUILD b/testing/xvidtune/APKBUILD
index 39080edae0..e6464fad9a 100644
--- a/testing/xvidtune/APKBUILD
+++ b/testing/xvidtune/APKBUILD
@@ -10,6 +10,14 @@ makedepends="libx11-dev libxxf86vm-dev libxaw-dev libxmu-dev libxt-dev"
subpackages="$pkgname-doc"
source="https://www.x.org/archive/individual/app/${pkgname}-${pkgver}.tar.bz2"
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ chmod +w config.guess config.sub
+ update_config_guess && update_config_sub
+}
+
build() {
cd "$builddir"
./configure \