aboutsummaryrefslogtreecommitdiffstats
path: root/testing/yubico-piv-tool
diff options
context:
space:
mode:
authorChristophe BERAUD-DUFOUR <christophe.berauddufour@gmail.com>2017-07-05 19:32:49 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-09-05 06:04:45 +0000
commit473db95ffd7aae42d29c9985385f39c14ffc0b56 (patch)
tree22b31fe315f5ae5494829cb231d828a02b4cf34a /testing/yubico-piv-tool
parent9737365dd18d9c2a12c64abd2e2bf9f5aacb8db5 (diff)
downloadaports-473db95ffd7aae42d29c9985385f39c14ffc0b56.tar.bz2
aports-473db95ffd7aae42d29c9985385f39c14ffc0b56.tar.xz
testing/yubico-piv-tool: new aport
https://developers.yubico.com/yubico-piv-tool PIV Tools for Yubikey (generate keys, import certificates, etc). [TT: fix indent, add check(), split -dev, --disable-static]
Diffstat (limited to 'testing/yubico-piv-tool')
-rw-r--r--testing/yubico-piv-tool/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/yubico-piv-tool/APKBUILD b/testing/yubico-piv-tool/APKBUILD
new file mode 100644
index 0000000000..dec92431ba
--- /dev/null
+++ b/testing/yubico-piv-tool/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Christophe BERAUD-DUFOUR <christophe.berauddufour@gmail.com>
+# Maintainer: Christophe BERAUD-DUFOUR <christophe.berauddufour@gmail.com>
+pkgname=yubico-piv-tool
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="PIV Tools for yubikey"
+url="https://developers.yubico.com/yubico-piv-tool"
+arch="all"
+license="BSD"
+depends=""
+makedepends="libc-dev gcc libressl-dev libcrypto1.0 libressl2.5-libcrypto pcsc-lite-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://developers.yubico.com/yubico-piv-tool/Releases/yubico-piv-tool-1.4.3.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="37e9691cf0ed7b9877ec2d51323f58801bf7b884fd3c64762a9421a017ca4ee2af7a1bb1b95b9657fdd8463dd9b93ae53de8ab390f71fb7635b332a5d2414632 yubico-piv-tool-1.4.3.tar.gz"