aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zutils/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-06 22:05:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-15 13:51:58 +0000
commit4f8166b125558b4668b8b954bb27ee3769c780ea (patch)
tree8fe506bdd9bd6c19dd3e723dc74cba6103c407f1 /testing/zutils/APKBUILD
parent8d6b38cd7c22cf6d2565891d72315428b521c340 (diff)
downloadaports-4f8166b125558b4668b8b954bb27ee3769c780ea.tar.bz2
aports-4f8166b125558b4668b8b954bb27ee3769c780ea.tar.xz
testing/zutils: new aport (closes #8382)
Zutils is a collection of utilities able to process any combination of compressed and uncompressed files transparently.
Diffstat (limited to 'testing/zutils/APKBUILD')
-rw-r--r--testing/zutils/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/zutils/APKBUILD b/testing/zutils/APKBUILD
new file mode 100644
index 0000000000..5cc8d9c50e
--- /dev/null
+++ b/testing/zutils/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=zutils
+pkgver=1.6
+pkgrel=0
+pkgdesc="A collection of utilities able to process any combination of compressed and uncompressed files transparently"
+url="http://www.nongnu.org/zutils/zutils.html"
+arch="all"
+license="GPL-2.0"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.lz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="afafd00a61fe28d597add0935c37b1854cff6627faaae20fe6dd1e553458f04b084c6bd2cc72410f239ab5506ba06f84366a73d28d8c7e788a01c14cc4085ecd zutils-1.6.tar.lz"